Hey Guys...
Great work on this upgrade/rewrite. It's good stuff. However...(you knew there would be a "however"...) Captcha doesn't seem to work in Safari (mac). I'm running Safari 2.0.4 (not the beta) and captcha fails usually. The error I get is: Captcha token test failed

I've also had one instance of someone using Firefox having it fail...so maybe it's not Safari. It's the same ol' thing, though...if you try a few times, it eventually works, but usually not the first time.

I don't have much info to give you on what's wrong...just thought I'd share my experience.

Comments

Priority:Normal» Critical
Status:Active» Postponed (maintainer needs more info)

Thanks for reporting it bob.
Any one can reproduce this?
I don't have an Mac to try, and in my Gentoo it's working perfectly.

Are you using a clean installation Bob?

Are you using Captcha 5.x-3.x-dev? What captcha challenge are you using?

Hey Guys...
I'm using captcha 3.0-rc1 (not the dev) and I've tried both the Image and Math versions...both fail randomly. The installation is pretty clean (although it's a multisite setup).

I think maybe the Image version worked better once I removed all the wacky characters such as #$%& from the challenge, but that doesn't really make much sense.

Is that "Captcha token test failed" error just a generic "captcha failed" message or is it more specific? I'm not much help, I know...any ideas on what I could do to test it further? It seems like it's the old browser cache issue that previous versions have had...but that's just a guess.

Try out Captcha 5.x-3.x-dev... There have been a bunch of bug fixes and features that have been put in since RC1. The math challenge shouldn't give you any problems.

I'm using captcha 3.0-rc1 (not the dev)

Try using dev for testing. Captcha-3.0-rc1 should have been called beta1 or something, it was not really release candidate quality IMHO. The current dev version should be much better. HEAD is pretty stable now.

Is that "Captcha token test failed" error just a generic "captcha failed" message or is it more specific?

The captcha token test is done before checking the actual captcha response, so it does not depend on answering right or wrong. There must be some problem with registering the solution in the session variable.

You also mentioned that it also fails with Firefox. Can you confirm this? I guess the problem has nothing to do with the browser, since the error message is related to server side session variables. Can you also describe your server setup?

Thanks for staying on top of this guys...it's awesome to see such responsiveness since you two have started on the module:

Yes, I can confirm the problem is in Firefox as well. So, if it's not browser specific, maybe my server setup will help. I'm not a server guy, but I'll do my best to let you know what's up:

-Using a Media Temple gridserver account
-PHP 4.4.7
-MySQL 4.1.11

not sure what other info you'd need...

It couldn't be the server checking stuff, could it?

Please try Captcha 5.x-3.x-dev first and report if the error still exists.

Status:Postponed (maintainer needs more info)» Fixed

Ok, no errors since the upgrade. Thanks guys! Marking it fixed in the new version...

Status:Fixed» Closed (fixed)