From, http://drupal.org/node/1705748#comment-6422184:

Actually, before we jump too fast. Based on your comment http://drupal.org/node/1717868#comment-6422150 I looked into the --verbose flag which I remember existing, but not to replace the simpletest_verbose variable.

--verbose Output detailed assertion messages in addition to summary.
Which is intended to spit out the individual row-by-row messages (assertions) in the output of the run-tests.sh script. Which is quite different from the simpletest_verbose variable which was to control the verbose page capturing functionality in DrupalWebTestCase.

We probably want to split these out and rename one. May also want to default to false on the command line? dunno.

I think --verbose flag as it stand now works the way that is most consistent with other scripts and makes sense. Perhaps we rename simpletest_verbose variable to 'capture' or something along those lines to 'capture browser shot' etc. I don't like those names just providing a thought basis.

If we default cli to false then using the cli then might do.

--print-details --verbose

--print-details to print out assertion messages
--print-results
--results
--details
,etc

Once committed http://drupal.org/node/1719530#comment-6427162 should be reverted.

Files: 
CommentFileSizeAuthor
#12 1774002.12.patch4.4 KBalexpott
PASSED: [[SimpleTest]]: [MySQL] 63,724 pass(es).
[ View ]
#9 1774002-9-verbose-browser.patch1.2 KBboombatower
PASSED: [[SimpleTest]]: [MySQL] 41,900 pass(es).
[ View ]
#6 1774002-6-verbose-browser.patch1.54 KBboombatower
PASSED: [[SimpleTest]]: [MySQL] 41,425 pass(es).
[ View ]

Comments

Issue tags:+Testing system

I actually don't quite understand the differentiation you're trying to make -- can you clarify a bit more?

Are you thinking of a --verbose-browser option?

Yea, --verbose-browser is a good name. I was having a hard time coming up with a good name for the flag.

The difference being that simpletest_verbose (--verbose-browser) controls the internal browser collecting, saving, and outputting links to the page output from each request. Whereas --verbose simply prints the messages that are already being collected...it just is "more verbose" in it's output to the user.

They seem to do fairly different things (although, --verbose-browsers should require --verbose) and only one has a performance hit it seems like they should be separate flags, but if so then --verbose-browser should probably automatically enable --verbose flag for simplicity and ease-of-use.

Title:Create run-tests.sh flag for simpletest_verbose variable or merge with --verboseSplit Simpletest --verbose into --verbose-browser

Title:Split Simpletest --verbose into --verbose-browserAdd Simpletest --verbose-browser flag

There seems to be a misunderstanding as there is currently _NO_ way to trigger browser verbosity through a flag...which was my point in the other issue and why the testbot cannot control this given our new approach

Title:Add Simpletest --verbose-browser flagSplit Simpletest --verbose-browser flag

After some confusion summarized http://drupal.org/node/1705748#comment-6435582

The documentation needs to be fixed, which we can do when we split the flag or just fix docs if we choose not to.

  --verbose   Output detailed assertion messages in addition to summary.

Before http://drupal.org/node/1719530#comment-6326150 (adding --keep-results flag issue) that was correct. After adding it now also triggers the collection of browser requests (something that is/was a separate feature not controlled by the flag before).

The change did not simply allow a variable to be overridden using the flag it added meaning to the flag which never controlled the functionality of the variable before. These should probably have been split out into separate issues so things didn't get so confused.

Title:Split Simpletest --verbose-browser flagCorrect mistake introduced in simpletest cmi conversion by introducing --verbose-browser flag
Assigned:Unassigned» boombatower
Category:task» bug
Status:Active» Needs review
StatusFileSize
new1.54 KB
PASSED: [[SimpleTest]]: [MySQL] 41,425 pass(es).
[ View ]

I have not tested this.

Looks good to me.

I think we also want to update simpletest.module's config setting key from 'verbose' to 'verbose_browser'.

sounds like a reasonable addition

StatusFileSize
new1.2 KB
PASSED: [[SimpleTest]]: [MySQL] 41,900 pass(es).
[ View ]

How about adding --print-assertions which is probably better since $verbose can be used for other things and seems more accurate since we simply print assertions which isn't really a normal definition of verbose.

Ugh, no please not. --verbose is clear. Let's get back to the previous patch, do the adjustment in #7, and be done with it.

hmm, I mean not like we call the assertions in web interface verbose. Seems like we would need to change the assertions with link text of verbose and the directory to verbose_browser...etc to be consistent, vs verbose being used to be literally verbose things such as browser dumps and something else to print assertions.

Seems like if we want to correctly fix and still use two verbose flags we need to make a lot of other changes some of which don't make a whole lot of sense which is what led me to change directions.

Issue summary:View changes
StatusFileSize
new4.4 KB
PASSED: [[SimpleTest]]: [MySQL] 63,724 pass(es).
[ View ]

The patch attached implements --verbose-browser flag and allows the run-tests.sh to override whatever is set in the simpletest.settings using this flag. The --verbose flag in run-tests.sh is only for printing the results of test assertions.

"verbose browser" to me sounds like a tool to browse verbose output.
"capture browser" makes more sense to me, or perhaps "capture HTML" (not that it will always be HTML).