If the video files are being stored in the private area, in Safari (on windows & ipad), it loads the image and when you click play you get the spinning wheel. The video never plays.
The video work just fine on Chrome, Firefox, IE 7 - 9 (all on windows.)

I can't link you to site because its private videos and requires a private login.

Any suggestions what to look for?

In the .htaccess in the private folder I added the following:
AddType video/ogg .ogv
AddType video/mp4 .mp4
AddType video/webm .webm

Comments

Added note:

I took the html5 video code that was being created and put it into a simple html and importing the needed js & css file into header and made two copies of it.
The first version I try use the private url to the mp4.
The second version I made a copy of the mp4 and put it some folder and html and accessed it directly (bypassing drupal)
The first version doesn't work.
The second version does work.
So I know its somehow the serving of these files from the private folder causing the issue

Excerpt from html file:
Note: I removed the real URL and replaced it with URL because it isn't accessible.

From Private Drupal URL (while logged in)
<video id="videojs-13-field-uploadvideos-video" data-setup="{}" class="video-js vjs-default-skin" width="640" height="480" controls="controls" preload="auto" poster="http://URL.com/system/files/FirstFrame%2001.png">
  <source src="http://URL.com/system/files/Intro_2.mp4" type="video/mp4" />
</video>
Direct Load
<video id="videojs-13-field-uploadvideos-video" data-setup="{}" class="video-js vjs-default-skin" width="640" height="480" controls="controls" preload="auto" poster="http://URL.com/system/files/FirstFrame%2001.png">
  <source src="http://URL.com/Intro_2.mp4" type='video/mp4'>
</video>

Status:Active» Postponed (maintainer needs more info)

Install and enable either the Resumable Download module (http://drupal.org/project/resumable_download) or the X-Sendfile module (http://drupal.org/project/xsendfile). The first one is very easy to install, but the second one will also give you better performance.

Thanks that alleviated some of the problem. Safari on windows isn't working still but Safari on osx is working now. So good enough. (most windows user don't use safari on windows.)

Status:Postponed (maintainer needs more info)» Closed (won't fix)

As Safari on Windows has been discontinued, I am not going to investigate this issue more.