As of creating this issue the tests (http://qa.drupal.org/pifr/test/333418) pass on the 8.x-3.x branch. If there is anything upstream that breaks them again, please "re"-open this issue or create a new one.

The relevant commits for the port are:
- Initial port:
http://drupalcode.org/project/libraries.git/commit/4c4321a4be79080e5c49a...
- Remove leftover libraries.test:
http://drupalcode.org/project/libraries.git/commit/93af70dfc948bad8dbb95...

Files: 
CommentFileSizeAuthor
#2 1779714-2-readme-and-js.patch1.2 KBtstoeckler
FAILED: [[SimpleTest]]: [MySQL] Unable to apply patch 1779714-2-readme-and-js.patch. Unable to apply patch. See the log in the details link for more information.
[ View ]

Comments

Status:Fixed» Needs work

From @klonos in #1167496-19: Libraries API in core:

The README in 8.x still says:

...external libraries is separate from installing this module and should happen in the sites/all/libraries directory.

Aren't we going for the top-level /libraries directory similar to how D8 contrib has moved to top-level /modules, /themes, /profiles?

I already updated libraries_get_path(), but we should also update the documentation.

Status:Needs work» Needs review
StatusFileSize
new1.2 KB
FAILED: [[SimpleTest]]: [MySQL] Unable to apply patch 1779714-2-readme-and-js.patch. Unable to apply patch. See the log in the details link for more information.
[ View ]

Drupal core removed the type="text/javascript" from output JS, which broke our tests.
Patch attached. Will commit this next time I see this. Reviews are, of course, welcome.

Status:Needs review» Fixed

Actually, because this was making tests fail, I actually went ahead and committed this. That makes it easier to go ahead with the refactoring.

Thanks again @klonos, for noticing the outdated text in README.txt!

http://drupalcode.org/project/libraries.git/commit/edf62a33b5ed9fb300ff0...

Status:Fixed» Closed (fixed)

Automatically closed -- issue fixed for 2 weeks with no activity.