Hi! Having Ruby installed via RVM.

I've followed your beautiful PDF manual carefully. When running compass create aurtest -r aurora --using aurora/susy, i receive the following error:

        /var/aegir/.rvm/gems/ruby-1.9.3-p194@global/gems/bundler-1.2.1/lib/bundler/shared_helpers.rb:22:in `default_gemfile': Could not locate Gemfile (Bundler::GemfileNotFound)
        from /var/aegir/.rvm/gems/ruby-1.9.3-p194@global/gems/bundler-1.2.1/lib/bundler.rb:222:in `default_gemfile'
        from /var/aegir/.rvm/gems/ruby-1.9.3-p194@global/gems/bundler-1.2.1/lib/bundler.rb:173:in `root'
        from /var/aegir/.rvm/gems/ruby-1.9.3-p194@global/gems/bundler-1.2.1/lib/bundler.rb:179:in `app_config_path'
        from /var/aegir/.rvm/gems/ruby-1.9.3-p194@global/gems/bundler-1.2.1/lib/bundler.rb:191:in `settings'
        from /var/aegir/.rvm/gems/ruby-1.9.3-p194@global/gems/bundler-1.2.1/lib/bundler.rb:324:in `configure_gem_home_and_path'
        from /var/aegir/.rvm/gems/ruby-1.9.3-p194@global/gems/bundler-1.2.1/lib/bundler.rb:86:in `configure'
        from /var/aegir/.rvm/gems/ruby-1.9.3-p194@global/gems/bundler-1.2.1/lib/bundler.rb:142:in `definition'
        from /var/aegir/.rvm/gems/ruby-1.9.3-p194@global/gems/bundler-1.2.1/lib/bundler.rb:112:in `setup'
        from /var/aegir/.rvm/gems/ruby-1.9.3-p194@global/gems/bundler-1.2.1/lib/bundler.rb:128:in `require'
        from /var/aegir/.rvm/gems/ruby-1.9.3-p194/gems/compass-0.13.alpha.0/bin/compass:25:in `<top (required)>'
        from /var/aegir/.rvm/gems/ruby-1.9.3-p194/bin/compass:19:in `load'
        from /var/aegir/.rvm/gems/ruby-1.9.3-p194/bin/compass:19:in `<main>'
        from /var/aegir/.rvm/gems/ruby-1.9.3-p194/bin/ruby_noexec_wrapper:14:in `eval'
        from /var/aegir/.rvm/gems/ruby-1.9.3-p194/bin/ruby_noexec_wrapper:14:in `<main>'

Totally confused.

Comments

Status:Active» Postponed (maintainer needs more info)

This is an RVM issue; RVM can't find the Ruby gem.

I don't use RVM, so I'm not 100% sure what the issue is, but it sounds like the issue is a missing Gemfile which is, if I understand RVM correctly, how RVM figures out what gems and at what version to use. Do you have a Gemfile? If so, did you include the Compass Aurora gem and proper version in there?

Status:Postponed (maintainer needs more info)» Closed (fixed)

This is a bug in Compass. It showed after an update in Bundler.

http://stackoverflow.com/questions/10610254/cant-install-compass-via-rvm

Sorry for bothering.

Not a problem. Was going to point you to this, but glad you found it.