When visiting /forum I get:

Fatal error: Unsupported operand types in /home/account/public_html/drupal/includes/theme.inc on line 1071
PathInfo: forum is served by advanced_forum_forum_page, implemented by advanced_forum in /home/account/public_html/drupal/sites/all/modules/advanced_forum/plugins/tasks/forum.inc at line 61

When I load the Modules page, I get this after visiting /forum and getting that error above (did not before visiting the forum page), maybe it will help in debugging:

Notice: Undefined offset: 1 in advanced_forum_preprocess_views_view__advanced_forum_topic_list() (line 366 of /home/account/public_html/drupal/sites/all/modules/advanced_forum/includes/theme.inc).
Notice: Trying to get property of non-object in advanced_forum_preprocess_views_view__advanced_forum_topic_list() (line 367 of /home/account/public_html/drupal/sites/all/modules/advanced_forum/includes/theme.inc).

Advanced Forum 7.x-2.0+29-dev

Comments

Reverting to old 2.0 to see if I have any better luck.

Status:Active» Postponed (maintainer needs more info)

Better luck with 2.0?

Can you write those problematic lines from 2.0+29-dev (366 and 367 from /home/account/public_html/drupal/sites/all/modules/advanced_forum/includes/theme.inc)?

Sorry I didn't report back. Actually, after reverting back, I didn't even remember to try (move along, move along).

Just now when trying I am actually able to see the forum for the first time (though haven't really tried much, busy building out other stuff)!

I'm not sure what you're asking for with "Can you write those problematic lines"? I've likely overwritten/replaced that newer copy now with the older 2.0 version but if you need me to just find a backup and copy/paste those two lines 366 and 367 from ../advanced_forum/includes/theme.inc just let me know that's what you need.

FYI, I imagine those lines come from the newest dev version, so you could just download the latest.

Status:Postponed (maintainer needs more info)» Fixed

Patch committed.

Status:Fixed» Closed (fixed)

Automatically closed -- issue fixed for 2 weeks with no activity.