The latest development snapshot of entity_translation module (which is soon to be released as beta version) requires two parameters while calling the function entity_translation_tab_access(). The first parameter is entity type and the second one is the entity.

Currently commerce_product module only has the first parameter which works with previous version of entity_translation. Now because of the missing parameter in the function call, this throws a warning and subsequently a fatal error which is why I have marked this issue critical.

Following is the error that I received when navigating to admin/commerce/products

Warning: Missing argument 2 for entity_translation_tab_access(), called in sites/all/modules/contrib/commerce/modules/product/commerce_product.module on line 890 and defined in entity_translation_tab_access() (line 678 of /sites/all/modules/contrib/entity_translation/entity_translation.module).
    EntityMalformedException: Missing bundle property on entity of type commerce_product. in entity_extract_ids() (line 7562 of /includes/common.inc).

The solution is very simple however. The function call entity_translation_tab_access() just needs to be called with the second parameter by passing the product entity.

Patch follows. Patch is simple and straight forward. Without this, entire product adminstration is not unusable.

Files: 
CommentFileSizeAuthor
#1 entity_translation-bug-fix-issue-1818496.patch696 byteskrishworks
PASSED: [[SimpleTest]]: [MySQL] 3,570 pass(es).
[ View ]

Comments

Status:Active» Needs review
StatusFileSize
new696 bytes
PASSED: [[SimpleTest]]: [MySQL] 3,570 pass(es).
[ View ]

patch attached.

Status:Needs review» Closed (duplicate)

#1495570: Update Entity translation integration already addresses this patch as part of the many other things it tries to solve. Marking this issue as duplicate.