Hi!

I'm using Fieldgroups to show vertical tabs on a node.

When using AT Core 7.x-3.1 or Corolla 7.x-3.0-rc1, I can see "(active tab)" below the tab name:
ATCore

The HTML code reads:
<span id="active-vertical-tab" class="offscreen">(active tab)</span>

However, using Bartik theme, it works correctly:
Bartik

And the HTML code now reads:
<span id="active-vertical-tab" class="element-invisible">(active tab)</span>

Is this a bug related to AdaptiveTheme? If not, I'm sorry.

If you need any more information or details, please let me know.

Thank you very much for your help.

Files: 
CommentFileSizeAuthor
#6 offscreen_css-1820938-6.patch457 bytesBWPanda

Comments

I cant remember why I did this, there were many issues with the vertical tabs in the past in Drupal core so I need to review my logic on this one, looks like a bug that needs to be fixed.

It would be great to have it fixed.

Thanks!!

I can only assume this CSS is missing from Corolla:

.offscreen {
    height: 1px;
    outline: 0 none;
    overflow: hidden;
    position: absolute;
    top: -99999em;
    width: 1px;
}

That is the magic, in AT Core I can't reproduce this.

Project:AdaptiveTheme» Corolla
Version:7.x-3.1» 7.x-3.x-dev
Component:CSS/HTML» Design

That dit it!

By the way, it happens the same to me with ATCore and Corolla. Adding that CSS it works fine but without it, "(active tab)" is showing. Are you sure it's a Corolla bug?

Thank you very much!

Status:Active» Needs review
StatusFileSize
new457 bytes

Here's a patch that adds the CSS from #3 to forms.css.