I have the latest Libraries release version and the latest Commons dev. This has in occurred in the last couple of dev releases on both windows and nix. I'm not sure if this is suppose to happen, and I'm not finding anything on it, so I thought I would mention it.

You are unable to use the customize feature on home and group landing pages, and the admin filter menu is disabled as well as other JavaScript features.

I tested it on firefox, but forgot to test on others.

Comments

Are you showing any errors in the Javascript error console?

SCRIPT5007: Die Eigenschaft "settings" eines undefinierten oder Nullverweises kann nicht abgerufen werden.
timeago.js, Zeile 13 Zeichen 1
SCRIPT438: Das Objekt unterstützt die Eigenschaft oder Methode "timeago" nicht
timeago.js, Zeile 3 Zeichen 5

SCRIPT5007: "settings" is undefined or null
timeago.js, line 13 character 1
SCRIPT438: Object does not support the property or method "timeago"
timeago.js, line 3 character 5

The problem is the jquery.timeago.js file.

seems to the drush make file fails when try to download the jquery.timeago.js plugin.

this is what contains the jquery.timeago.js file after to run drush make:

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01//EN" "http://www.w3.org/TR/1999/REC-html401-19991224/strict.dtd">
<!-- <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN"
"http://www.w3.org/TR/html4/strict.dtd"> -->
<HTML>
<HEAD>
<META HTTP-EQUIV="Refresh" CONTENT="0.1">
<META HTTP-EQUIV="Pragma" CONTENT="no-cache">
<META HTTP-EQUIV="Expires" CONTENT="-1">
<TITLE></TITLE>
</HEAD>
<BODY><P></BODY>
</HTML>

In the meanwhile you can download the file from here:

http://timeago.yarp.com/jquery.timeago.js

And put the file in

profiles/commons/modules/contrib/timeago

And now all should work fine.

Doesn't work.

Title:Enabling latest Libraries breaks Javascript and panels.Switch to specific hash of Timeago library

Thanks for the troubleshooting, gnuget!

I switched us to downloading the master version of the library from github and it appears to download with the right file contents.

http://drupalcode.org/project/commons.git/commit/751bd3b

I re-opened #1821996: Please include Time Ago library in whitelist to allow us to use a specific commit hash from github so that we can use a known version of the library in the long-term.

Category:bug» task
Status:Active» Postponed

@geigerg - Did you clear your site cache and shift+refresh your browser?

I have replaced the file before setup - still the same error as on #2.

@geigerg

Make sure to delete the old jquery.timeago.js before to download the new one.

I'm sure with this should work

Latest dev - still the same problem.

Here the firebug output.

TypeError: jQuery.timeago is undefined
[Break On This Error]
jQuery.timeago.settings.strings = {
timeago.js?mcwqgx (line 13)

TypeError: jQuery("abbr.timeago, span.timeago, time.timeago", context).timeago is not a function
[Break On This Error]
jQuery('abbr.timeago, span.timeago, time.timeago', context).timeago();

I haven't had a chance to test it yet, but I did grab the latest code to look at. I'm trying my best to understand Drupal, but if I had to guess the problem is the the timeago.js file is not included in the timeago.info file.

scripts[] = timeago.js

StatusFileSize
new739 bytes

I'm sure this is not needed, but I was anxious to throw my first patch out and get the process down.
Edit: I corrected a typo is also why I posted the patch just in case it was missed.
Edit: Actually I think it might depend on comment #5

Topcheese

The js file is not added at the info file because is not part of the module, that plug in needs to be downloaded separately.

So, the bug is related with drush make because fails when download the js file and not with the module in self, Geirger you are doing something wrong I think, because this should work, can you double check if the file is in the correct place?

Checked it again - latest dev (2012-02-11), Setup on Aquira Dev Desktop
As long libraries api is disabled timeago and other js are working fine. After enabling libraries all js is broken.

So, I doubt that this will fix geigerg's problem, but re: the file not downloading, using drush 4.5 (the version from ubuntu 12.04) will not download the jquery.timeago.js unless you include the overwrite flag. See attached patch if you would like to support that. So far as I can tell it doesn't break 5 either.

...and this one passes verify-makefile.

This is not a downloading problem - see #15 : since #5 the jquery.timeago.js is in place and working.
After enabling the libraries module all js is broken. After disabling all js incl. jquery.timeago.js is working fine.

Maybe this will help - I will test it later.

http://drupal.org/node/1832550

Status:Postponed» Needs review

Timeago latest DEV, moved jquery.timeago.js to /sites/all/libraries/timeago/ -> works fine.

I'll have to check again, but I'm pretty sure it doesn't work correctly on comment display. Instead of the rendered output it's showing the span tag.

Thanks for the bug report, Topcheese. This seems unrelated to using a specific hash of the Timeago library -- I re-opened #1838928: Timeago display displays HTML on comments so we can track the incorrect formatting.

No problem ezra-g, I love doing this kind of stuff. Well, maybe I should post a problem while I'm at it. I believe we are talking about two different issues here. The original problem described above and as described in #18 still exist with the latest dev? Enabling Libraries breaks Javascript, so are there not plans to support Libraries module, and should I post a new issue?

Title:Switch to specific hash of Timeago librarySwitch to specific hash of Timeago library/ Drush 4.6 Aegir Compatibility

Status:Needs review» Reviewed & tested by the community

With the patch, I can now build a platform on Aegir.

(it still fails creating a site, so I'll either continue in the other issue or create a new one shortly)

If have applied the patch in #17, but I can't create a platform. I get an error:

Directory not empty: /tmp/drush_make_tmp_1354618899_50bdd81366585/__build__/profiles/commons/modules/contrib/timeago

Any ideas?

Status:Reviewed & tested by the community» Fixed

This should now be fixed with #2012832: Timeago Library Update.

Status:Fixed» Closed (fixed)

Automatically closed -- issue fixed for 2 weeks with no activity.