I'm having an issue with Flexslider ver 2 where the first slide stays much longer than other slides. I have the slideshow speed set for 5000ms and have four slides. It looks like the first slide displays for 20,000ms (4 x 5000ms) and then other slides begin to show at the correct speed. This only happens when I'm using the animation "Fade", if "Slide" is used the first slide displays for the correct length of time. I've tried playing around with the starting slide setting it to 4 in the hope that it was trying to cycle through the slide show in regards to total time before displaying the second slide, but that only caused more issues with the timing.

Any ideas?

(Flex Slider, Flex Slider Views, Flex Slider Views Slideshow enabled all ver 7.x-2.x-dev, Drupal 7.17)

Comments

Status:Active» Postponed (maintainer needs more info)

Not sure, I'll have to do some testing on this one. Can you provide your optionset/views exports?

I've noticed a few weird bugs with the fade effect recently. Not sure if it's the library or something with the module.

Just confirming this problem, using 7.x-1.0-rc3 here, as a field formatter.

If you use fade, the first time you loop through all the images, you only see the first one (no changes). After the first loop it works correctly. I dont see any errors in js console or anything.

If you switch the effect to slide, then the carrusel works perfectly normal.

I'm having this exact same issue. Using 7.x-1.0-rc3. The initial image stays for the entire length of the slideshow then it starts and works correctly after that.

Not sure if it helps but I was able to confirm it was doing this by inspecting the slideshow in firebug and then reloading the page. I messed around with almost all the display options and it seemed to be directly linked with fade.

Status:Postponed (maintainer needs more info)» Active

Status:Active» Postponed (maintainer needs more info)

Does anyone get this issue with 2.x?

I still have this problem with 7.x-1.0-rc3

Version:7.x-2.x-dev» 7.x-1.0-rc3

Same for me, ver 7.x-2.0-alpha1. Temporary fix using Slide instead of Fade.

Version:7.x-1.0-rc3» 7.x-2.x-dev
Status:Postponed (maintainer needs more info)» Active