Hello!

I'm new to Drupal and just downloaded OpenChurch 7.x-1.0-beta5 (couldn't find an exact match in the drop-down Version menu) to use on a new church website I'm building. It looks like a great template for me to use, but I'm having two issues. First, the error code shown below keeps appearing:

"Notice: Undefined property: stdClass::$did in panels_panels_pane_content_alter() (line 77 of /home/clintwoo/public_html/drupal/sites/all/modules/fusion_accelerator/fusion_apply/modules/panels.fusion.inc).
Notice: Undefined property: stdClass::$did in panels_panels_pane_content_alter() (line 77 of /home/clintwoo/public_html/drupal/sites/all/modules/fusion_accelerator/fusion_apply/modules/panels.fusion.inc).
Notice: Undefined property: stdClass::$did in panels_panels_pane_content_alter() (line 77 of /home/clintwoo/public_html/drupal/sites/all/modules/fusion_accelerator/fusion_apply/modules/panels.fusion.inc).
Notice: Undefined property: stdClass::$did in panels_panels_pane_content_alter() (line 77 of /home/clintwoo/public_html/drupal/sites/all/modules/fusion_accelerator/fusion_apply/modules/panels.fusion.inc)."

I don't know enough about PHP to edit out this bug. Secondly, "Skinr can't apply your skin settings to this panel due to limitations in Panels module. Here is a workaround" keeps popping up on my admin homepage. The workaround link, http://drupal.org/node/1292662, isn't helpful, though. Could someone please help me?

Thanks!

Nate

Comments

Now the Fusion Accelerator issue has added a new line to its error message:

"Notice: Undefined property: stdClass::$did in panels_fusion_apply_preprocess_index_handler() (line 65 of /home/clintwoo/public_html/drupal/sites/all/modules/fusion_accelerator/fusion_apply/modules/panels.fusion.inc)."

The problem with line 77 still exists, too. Just wanted to update the report!

-Nate

Interesting bc we used to have this issue a long time ago but it was patched. I cannot recreate this problem. Can you tell me the exact steps to recreate this problem?

Status:Active» Needs work

Sorry for my delayed response. Unfortunately, I can't describe the exact steps I took to create the problem. I simply attempted to follow standard installation procedures, and these errors appeared!

What version of php are you using? What page are you on?

Version:7.x-1.11-beta5» 7.x-1.11-beta7
Priority:Normal» Critical

I updated my OpenChurch distribution to 7.x-1.11-beta7, and now everything has crashed! My website won't even allow me to log-in. The message I keep seeing declares, "Fatal error: Cannot redeclare simplenews_token_info() (previously declared in /home/clintwoo/public_html/drupal/sites/all/modules/openchurch/modules/contrib/simplenews/simplenews.module:2043) in /home/clintwoo/public_html/drupal/sites/all/modules/openchurch/modules/contrib/simplenews/simplenews.tokens.inc on line 73". Thus, I'm planning to wipe off everything from my server and start over. Unfortunately, I now plan to move on from OpenChurch. It's just too buggy for me to use. I can tell you that my PHP version is 5.3.18, though. Hopefully this information will help you to improve this distribution. Good luck and have a blessed 2013!

I'm also getting accelerator issues. - openchurch-7.x-1.11-beta7-core

    Notice: Undefined index: sidebar_tablet_landscape_enabled in _fusion_accelerator_save_grid() (line 465 of C:\projects\openchurch\drupal7\sites\all\modules\fusion_accelerator\fusion_accelerator.module).
    Notice: Undefined index: sidebar_tablet_portrait_enabled in _fusion_accelerator_save_grid() (line 465 of C:\projects\openchurch\drupal7\sites\all\modules\fusion_accelerator\fusion_accelerator.module).
    Notice: Undefined property: stdClass::$did in panels_panels_pane_content_alter() (line 77 of C:\projects\openchurch\drupal7\sites\all\modules\fusion_accelerator\fusion_apply\modules\panels.fusion.inc).
    Notice: Undefined property: stdClass::$did in panels_fusion_apply_preprocess_index_handler() (line 65 of C:\projects\openchurch\drupal7\sites\all\modules\fusion_accelerator\fusion_apply\modules\panels.fusion.inc).
    Notice: Undefined property: stdClass::$did in panels_panels_pane_content_alter() (line 77 of C:\projects\openchurch\drupal7\sites\all\modules\fusion_accelerator\fusion_apply\modules\panels.fusion.inc).
    Notice: Undefined property: stdClass::$did in panels_fusion_apply_preprocess_index_handler() (line 65 of C:\projects\openchurch\drupal7\sites\all\modules\fusion_accelerator\fusion_apply\modules\panels.fusion.inc).
    Notice: Undefined property: stdClass::$did in panels_panels_pane_content_alter() (line 77 of C:\projects\openchurch\drupal7\sites\all\modules\fusion_accelerator\fusion_apply\modules\panels.fusion.inc).
    Notice: Undefined property: stdClass::$did in panels_fusion_apply_preprocess_index_handler() (line 65 of C:\projects\openchurch\drupal7\sites\all\modules\fusion_accelerator\fusion_apply\modules\panels.fusion.inc).
    Notice: Undefined property: stdClass::$did in panels_panels_pane_content_alter() (line 77 of C:\projects\openchurch\drupal7\sites\all\modules\fusion_accelerator\fusion_apply\modules\panels.fusion.inc).
    Notice: Undefined property: stdClass::$did in panels_fusion_apply_preprocess_index_handler() (line 65 of C:\projects\openchurch\drupal7\sites\all\modules\fusion_accelerator\fusion_apply\modules\panels.fusion.inc).

OK I will take a look this week

Alright, here's a bit more detail. I think the real issue may be in OpenChurch Starter 7.x-1.11-beta7, but you may want to take note, because it looks like there's something in fusion_accellerator-7.x-2.x-dev that may cause issues as well. Here's what I did:

  1. Installed openchurch-7.x-1.11-beta7-core.
  2. Enabled All openchurch themes, set OpenChurch Starter 7.x-1.11-beta7 theme as default
  3. On main menu click Ministries, then Home. Get the following error:
    • * Notice: Undefined index: sidebar_tablet_landscape_enabled in _fusion_accelerator_save_grid() (line 465 of C:\drupal7\profiles\openchurch\modules\contrib\fusion_accelerator\fusion_accelerator.module).
    • * Notice: Undefined index: sidebar_tablet_portrait_enabled in _fusion_accelerator_save_grid() (line 465 of C:\drupal7\profiles\openchurch\modules\contrib\fusion_accelerator\fusion_accelerator.module).
  4. After some Googleing, it looked like dev version of fusion_accelerator would do the trick, updated to fusion_accellerator-7.x-2.x-dev. This caused variations of the nasty error message in #7 with every openchurch theme.
  5. Reverted back to fusion_accelerator 7.x-2.0-beta1, OpenChurch 7.x-1.0-beta6
  6. All is right with the world.

Hope this helps somebody.

Status:Needs work» Needs review

Interesting I am not seeing any of these issues.

OK I see it now. It is dealing with the starter theme.

OK I have a patch that fixes the issue. This adds an "isset" around the index being checked by fusion.

OK I have added the patch to my openchurch .make file. I will do an end to end test later today. This is in 1x dev and should make a public release this weekend.

OK I have added the patch to my openchurch .make file. I will do an end to end test later today. This is in 1x dev and should make a public release this weekend.

Status:Needs review» Fixed

Pushed out in 7.x-1.11-beta8

Status:Fixed» Closed (fixed)

Automatically closed -- issue fixed for 2 weeks with no activity.