I upgraded a site from 6 to 7. In the modules listing in the CCK section, I have a line:

Content 6.x-2.9 This version is not compatible with Drupal 7.x and should be replaced.

I am not sure where or what I should do to get rid of that? Any hints?

Comments

I'm not sure but I think you need to look at this:
http://drupal.org/node/1144136 for migrating data from D6 to D7 using CCK
You probably need to uninstall your 6.x CCK module and install the 7.x dev version.
The release notes for the 7.x version say

This is the location for the code that is not in core in D7. Note that many files were added and then later removed as various parts of the code were moved to core during the D7 cycle. The code will not work correctly if those files are not removed, so be sure you clean out old files when updating this code.

Status:Active» Fixed

You don't 'uninstall' the D6 version, you just need to completely remove all D6 code before dropping the D7 code in place.

Um, yes. But how can I identify the culprit now that everything is in place?

Status:Fixed» Closed (fixed)

Automatically closed -- issue fixed for 2 weeks with no activity.