There are 3 things which I would propose to fix/improve in the hook_views_plugins documentation:

  1. change "An array on the form..." to "An array of the form..."
  2. change "plugin" to "PLUGIN TYPE" where that is what is meant
  3. add a colon to introduce the list of PLUGIN TYPE options, to make it clearer to the reader that they are about to read a list of options

Current comment:
* An array on the form $plugins['PLUGIN TYPE']['PLUGIN NAME']. The plugin
* must be one of row, display, display_extender, style, argument default,
* argument validator, access, query, cache, pager, exposed_form or
* localization.

Proposed comment:
* An array of the form $plugins['PLUGIN TYPE']['PLUGIN NAME']. The PLUGIN TYPE
* must be one of: row, display, display_extender, style, argument default,
* argument validator, access, query, cache, pager, exposed_form or
* localization.