I have tried to install this distribution using both the current and dev versions. I have tried installing apps and tried installing without any apps. I can't get it to install without the following errors:

Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, salomos@comcast.net and inform them of the time the error occurred, and anything you might have done that may have caused the error.
More information about this error may be available in the server error log.

The apache error log shows the following alerts:
[Mon Dec 10 17:36:16 2012] [warn] [client 127.0.0.1] mod_fcgid: stderr: PHP Fatal error: __clone method called on non-object in C:\\Users\\salomos\\Sites\\TGS2\\profiles\\openoutreach\\openoutreach.profile on line 147, referer: http://tgs2.org:8082/install.php?profile=openoutreach&locale=en
[Mon Dec 10 17:39:55 2012] [warn] [client 127.0.0.1] mod_fcgid: read timeout from pipe, referer: http://tgs2.org:8082/install.php?profile=openoutreach&locale=en
[Mon Dec 10 17:39:55 2012] [error] [client 127.0.0.1] Premature end of script headers: install.php, referer: http://tgs2.org:8082/install.php?profile=openoutreach&locale=en
[Mon Dec 10 17:40:07 2012] [warn] mod_fcgid: process 10492 graceful kill fail, sending SIGKILL

I really would like to use this but I can't find a way around this error.

Comments

Title:Internal Server Error every time I try to installPHP Fatal error: __clone method called on non-object

The fatal error relates to code we recently cribbed from the Commerce Kickstart project, see #1852898: Filter update messages to show updates for security issues, customized modules/themes, or the distro itself. I haven't hit the error--it may relate to specific PHP versions or other server-specific conditions.

I looked more closely at the clone error. It looks like it would occur only if Drupal were unable to find the openoutreach profile, which would result in that key being missing in the array of system data returned. But since the code is being called from within openoutreach.profile, it's hard to see why that would happen, and since I can't reproduce the issue it's not easy to debug.

Status:Active» Postponed (maintainer needs more info)

I'm unable to reproduce this error. Please provide steps to reproduce it from a clean install.

Version:7.x-1.0-rc7» 7.x-1.x-dev
Issue summary:View changes
Status:Postponed (maintainer needs more info)» Fixed

I added a test to ensure the data exists before cloning.

Status:Fixed» Closed (fixed)

Automatically closed - issue fixed for 2 weeks with no activity.