Drush 5 is expected to raise an error message is run over drupal 8, but this happens:

# drush status
Drush 5.0-dev does not support Drupal . Use Drush 4 instead.                                                                                                                                            [error]
PHP Fatal error:  Call to undefined function conf_path() in /usr/src/drush/includes/bootstrap.inc on line 784
PHP Stack trace:
PHP   1. {main}() /usr/src/drush/drush.php:0
PHP   2. drush_main() /usr/src/drush/drush.php:16
PHP   3. _drush_bootstrap_and_dispatch() /usr/src/drush/drush.php:61
PHP   4. drush_bootstrap_to_phase() /usr/src/drush/drush.php:81
PHP   5. drush_bootstrap_max() /usr/src/drush/includes/bootstrap.inc:291
PHP   6. drush_bootstrap_validate() /usr/src/drush/includes/bootstrap.inc:343
PHP   7. _drush_bootstrap_drupal_site_validate() /usr/src/drush/includes/bootstrap.inc:267
Drush command terminated abnormally due to an unrecoverable error.                                                                                                                                      [error]
Error: Call to undefined function conf_path() in /usr/src/drush/includes/bootstrap.inc, line 784

This is a regression in commit d19345279a152ea4117ef9af24ab409e4ae252a4

Comments

Status:Fixed» Closed (fixed)

Automatically closed -- issue fixed for 2 weeks with no activity.