compass watch
>>> Change detected at 15:39:59 to: style.scss
error sass/style.scss (Line 20 of sass/partials/global/_base.scss: File to import not found or unreadable: aurora/susy-grid.
Load paths:
/Applications/MAMP/htdocs/txmo/sites/all/themes/txmo_aurora/sass
/Users/davidfells/.rvm/gems/ruby-1.9.3-p362/gems/compass-0.12.2/frameworks/blueprint/stylesheets
/Users/davidfells/.rvm/gems/ruby-1.9.3-p362/gems/compass-0.12.2/frameworks/compass/stylesheets
Compass::SpriteImporter)

Mac OS Mountain Lion, Ruby 1.9.3, latest versions of all required gems, Drupal 7.14, Aurora 2.6. Came across another bug where the indicated answer was to update gems/etc, but that doesn't seem to be applicable for me.

Comments

Run the following in your command line. The issue is most definitely because Compass can't find the gem.

gem list compass-aurora

Also, make sure that require 'aurora' is in your config.rb file.

That require is line 1 in the config.rb file.

Davids-MacBook-Pro:txmo_aurora davidfells$ gem list compass-aurora

*** LOCAL GEMS ***

compass-aurora (1.0.2)
Davids-MacBook-Pro:txmo_aurora davidfells$ compass watch
>>> Change detected at 15:51:46 to: style.scss
error sass/style.scss (Line 20 of sass/partials/global/_base.scss: File to import not found or unreadable: aurora/susy-grid.
Load paths:
/Applications/MAMP/htdocs/txmo/sites/all/themes/txmo_aurora/sass
/Users/davidfells/.rvm/gems/ruby-1.9.3-p362/gems/compass-0.12.2/frameworks/blueprint/stylesheets
/Users/davidfells/.rvm/gems/ruby-1.9.3-p362/gems/compass-0.12.2/frameworks/compass/stylesheets
Compass::SpriteImporter)

Okay, this is an RVM issue. As I don't use RVM, I'm not sure exactly how to solve the issue, but I believe the issue you're having is that you've installed compass-aurora to system gems but rvm is looking for it in its directories, not finding it (lack of import path), and therefore failing. I believe the way you install a Ruby Gem to your RVM directory is rvm install so you'd do rvm install compass-aurora, but again, not using RVM, I'm not entirely sure. Alternatively, you can switch from your RVM to your system by running rvm use system and that should turf you back to your standard Ruby stuff and the gem should be found.

I installed it through JewelryBox (which is an RVM GUI I think). I should note that I had the exact same issue prior to using RVM - RVM was actually an attempt at solving this very problem, which came with the pre-installed Ruby + having installed the right gems.

Well then, unfortunately, I've got no idea. I, and everyone else I've worked with, have had no problem using this with system gems and I don't know enough about RVM to debug using RVM.

My suggestion is to try and use the system gems again. Make sure you've got Compass, Sass, and Compass-Aurora installed to the system folder. Remember that you'll probably need to sudo the installs of the gems

Davids-MacBook-Pro:txmo_aurora davidfells$ gem list aurora

*** LOCAL GEMS ***

aurora (0.2.0)
Davids-MacBook-Pro:txmo_aurora davidfells$ gem list compass-aurora

*** LOCAL GEMS ***

compass-aurora (1.0.2)
Davids-MacBook-Pro:txmo_aurora davidfells$ gem list compass

*** LOCAL GEMS ***

compass (0.12.2)
compass-aurora (1.0.2)
compass-normalize (1.4.2)
Davids-MacBook-Pro:txmo_aurora davidfells$ compass watch
>>> Change detected at 17:15:47 to: style.scss
error sass/style.scss (Line 20 of sass/partials/global/_base.scss: File to import not found or unreadable: aurora/susy-grid.
Load paths:
/Applications/MAMP/htdocs/txmo/sites/all/themes/txmo_aurora/sass
/Library/Ruby/Gems/1.8/gems/compass-0.12.2/frameworks/blueprint/stylesheets
/Library/Ruby/Gems/1.8/gems/compass-0.12.2/frameworks/compass/stylesheets
Compass::SpriteImporter)
overwrite css/style.css

That's non-RVM output

Status:Active» Postponed (maintainer needs more info)

The problem is that you have the ruby gem "aurora" and "compass-aurora" enabled. It is a weird compass namespacing thing, but having aurora also enabled will cause everything to break.

Remove the aurora compass extension and it should work.

Putting the issue as postponed, please close if that fixes it.

Status:Postponed (maintainer needs more info)» Closed (fixed)

Yes, that was it. Forgot to come back and close the issue when it was solved. Thanks!