Problem/Motivation

This is a followup issue for #1871696: Convert block instances to configuration entities to resolve architectural issues.

  • BlockBlock implements the BlockInterface settings(), access(), form(), validate(), submit(), and build() methods with general handling that should apply to all blocks, and then provides blockSettings(), blockAccess(), etc. methods for each that allow individual block plugins to add their own handling without having to reimplement the general handling.
  • From an architectural standpoint, it is correct for the interface to include only the methods that matter to callers and for these methods to have simple names. See #1535868-108: Convert all blocks into plugins, #1535868-335: Convert all blocks into plugins, and #1535868-340: Convert all blocks into plugins.
  • The fact that the block*() methods are named consistently makes the pattern easier to understand.
  • However, the naming is still potentially confusing since both (e.g.) build() and blockBuild() return render arrays for a block.

Proposed resolution

  • Discuss whether there is a better naming pattern for blockBuild(), blockSettings(), etc.

Comments

xjm’s picture

Status: Postponed » Active
xjm’s picture

xjm’s picture

Status: Active » Closed (duplicate)
xjm’s picture

Issue tags: +Block plugins