I started getting this message after updating a few modules, the first few updates went normally then I started getting this message when applying the update after downloading it.

This line reads:
$requirements['update_core'] = _update_requirement_check($data['drupal'], 'core');

I have found this issue listed in the openoutreach distribution issue cue, however there does not appear to be a fix.

Drupal 7.17

Install profile Commerce Kickstart (commerce_kickstart-7.x-2.0-rc4)

Comments

StatusFileSize
new50.04 KB

Same problem here:

Notice: Undefined index: drupal in update_requirements() (line 35 of C:\wamp\www\LocalDrupalStore\modules\update\update.install).

I had the Commerce Kickstart 7x. 2.0 rc4 installed and then i wanted to activate the Commerce Kickstart Menus Module.
I didn't like it so turned it off and then my toolbar was kinda broken (see attached image) and some of the toolbar links didn't open in an overlay.

I updated using commerce_kickstart-7.x-2.0-no-core but i still get the undefined index: drupal error and i have no idea how to make the toolbar look like it did before.

Can someone help us?

The parallel issue on Open Outreach is #1875386: Notice: Undefined index: drupal in update_requirements() (line 35 of .../modules/update/update.install).. I've posted a quick patch there that could be adapted for Kickstart but haven't yet looked closely at the issue or tested.

Just installed commerce quickstart 7.x-2.0 normally (following the directions) and got the same error.

Notice: Undefined index: drupal in update_requirements() (line 35 of /Sites/commerce_kickstart-2.0/modules/update/update.install).

Version:7.x-2.0-rc4» 7.x-2.x-dev
Status:Active» Needs review
StatusFileSize
new751 bytes

Patch adapted to kickstart.
Here's the gerrit commit : https://code.drupalcommerce.org/#/c/601/

@cn313
for

I had the Commerce Kickstart 7x. 2.0 rc4 installed and then i wanted to activate the Commerce Kickstart Menus Module.
I didn't like it so turned it off and then my toolbar was kinda broken (see attached image) and some of the toolbar links didn't open in an overlay.

Please continue on this issue for the toolbar (#1877594: Toolbar (administration menu) broken after disabling 'commerce kickstart menus')

Status:Needs review» Reviewed & tested by the community

I can confirm that the patch in #4 works for me. Since it's the exactly the same solution as applied in #1875386: Notice: Undefined index: drupal in update_requirements() (line 35 of .../modules/update/update.install). I'd recommend committing this in Kickstart too.

Status:Reviewed & tested by the community» Fixed

Committed!

I had the same problem, and by activating the PHP module, it's solved it !

Status:Fixed» Closed (fixed)

Automatically closed -- issue fixed for 2 weeks with no activity.

What PHP module?

PHP filter module