In the current BlockInterface, there are pairs of methods like access()/blockAccess() and submit()/blockSubmit().

With #1871696: Convert block instances to configuration entities to resolve architectural issues, the wrapping methods are moved to the Block entity class, so only the blockFoo() methods are left, and should be renamed.

Files: 
CommentFileSizeAuthor
#5 block-1884860-5.patch25.52 KBtim.plunkett
PASSED: [[SimpleTest]]: [MySQL] 50,683 pass(es).
[ View ]

Comments

Issue tags:+Blocks-Layouts

tagging

#1875770: Reconsider BlockBase::block*() method names is no longer relevant with this issue, so closing that as duplicate.

Issue tags:+Block plugins

Tagging.

Status:Postponed» Needs review
StatusFileSize
new25.52 KB
PASSED: [[SimpleTest]]: [MySQL] 50,683 pass(es).
[ View ]

We can only do settings and build for now, the rest are still being worked out.

Status:Needs review» Needs work
Issue tags:-Blocks-Layouts, -Block plugins

The last submitted patch, block-1884860-5.patch, failed testing.

Status:Needs work» Needs review
Issue tags:+Blocks-Layouts, +Block plugins

#5: block-1884860-5.patch queued for re-testing.

Status:Needs review» Reviewed & tested by the community

RTBC

Eclipse

Status:Reviewed & tested by the community» Fixed

Yes, please.

Committed and pushed to 8.x. Thanks!

Shall we update this change notice? http://drupal.org/node/1880620

Aye, please do.

Change notice updated :)

Assigned:tim.plunkett» Unassigned

Automatically closed -- issue fixed for 2 weeks with no activity.