I recently worked on a project where I needed to render a FlexSlider from an entityreference field. I used a custom content type for my slides, and added them to another entity - in my case a taxonomy term.

I created a quick module which provides a field formatter, reusing code from flexslider_fields and entityreference.

Hope somebody can check it out and give feedback in the project application issue.

Sandbox project: https://drupal.org/sandbox/bendik/1886168
Project application: https://drupal.org/node/1886184

Comments

Status:Active» Needs review

That's pretty sweet!

I'll try to provide some feedback in your project application. In the mean time, I'll setup a link on the project page. If it gets approved as a complete module ahead of time, let me know and I'll update the link on the project page.

Status:Needs review» Fixed

The module has made it out of the sandbox and is now published here: https://drupal.org/project/flexslider_entityreference

Remember that the module only works with the 2.x version of Flexslider. I'll try to make it work for v1 aswell, if you guys want it.

You can add a version dependency in your .info. Just add

dependencies[] = flexslider [2.x)

That should do it. It may throw warnings when using a checkout copy of the module or the dev version, but at least it will let the site builder know they're using the wrong version.

I'll update the link on the project page. Great job!

Status:Fixed» Closed (fixed)