Existing MailChimp list does not appear in admin/config/services/mailchimp/lists/1/edit MailChimp List after a drupal site move and upgrade.

An existing Drupal 6.9/ MailChimp 6.x-2.4 installation is being moved from a hosting service to a new VPS (with a new IP) The original site has a newsletter subscription block that updates MailChimp for authenticated users optioning to subscribe. This site is updating an existing mailchimp list of 403 total subscribers.

The site was moved and upgraded to Drupal 7.18 and MailChimp 7.x-2.8.. The MCAPI class library was installed. The new admin/config/services/mailchimp page shows the correct API key. However the subscription block disappeared in the upgrade.

The new upgrade site database has both a mailchimp_lists table with one list (the list ID matches the MailChimp List ID) and a mailchimp_user table with 231 current and 4 pending entries. Cron was run and both the "Add a list" and the Edit options on the existing list were attempted from the new site. 'Refresh lists from MailChimp' also ran and reported a successful update. However, the existing MailChimp list does not appear. The new site list options are Type=Optional. Synch during Cron, Roles: anonymous user. These can not be edited with out the required MailChimp list selection.

The API Call log shows current calls from the original hosting service IP addr. There are no calls from the new VPS IP addr. The calls from the old site seem to indicate an error "(200) List_DoesNotExist". However new subscribers using the old site subscription block show up in the MailChimp Dashboard.

Comments

Status:Active» Closed (fixed)

Upgrades from D6 are not supported and the architecture is completely different. You will need to follow the directions in relevant README files and/or review the MailChimp handbook pages on d.o. But you will, at the least, need to create all the lists you want to integrate with in mailchimp_lists.

I had the same problem.
Created a new list on Mailchimp Web site.
Generated a new API.
Ran Cron.
Updated lists in Mailchimp config.
Tried to create a new list in Mailchimp configuration in admin/config/services/mailchimp/lists/add but my mailing lists from the MailChimp site do not appear.

MailChimp 7.x-2.8 has been uninstalled. The mailchimp_lists table is gone. However, the mailchimp_user table remains. Should that table be truncated prior to any attempt to try another install of MailChimp 7.x-2.8?

I uninstalled mailchimp completely, then re-installed. That did not solve the issue. Running 7.x.2.9

Status:Closed (fixed)» Needs review

Perhaps a solution can be posted here that would resolve this issue?

Status:Needs review» Active

Needs review implies a patch that's awaiting review. I'm happy to leave this open to see if someone can provide support.

Thank for re-opening this case.

It might help us debug the issue if a developer could speculate as to what might cause the MailChimp module to not see the mailing lists on the MailChimp account.

The MailChimp account has one or more lists. The API code is correct. Caches have been cleared and Cron run. Yet, the MailChimp module still does not refresh the mailing lists and clicking Add a list does not work since the required pop up of lists does not show any lists. I also tried to use a different MailChimp account which I know works with another site of mine and that did not help.

Next I'll try to disable as many modules as possible to see if there is some interference going on.

Disabling modules did not work.

Version:7.x-2.8» 7.x-2.9
Category:support» bug
Priority:Normal» Critical

I just encountered the same problem on D 7.18. Mailchimp was working great in 2.7, but then updated to 2.9 and now it isn't loading the lists.

Status:Active» Closed (cannot reproduce)

Hey folks - This thread is not focused and doesn't provide any details. If you just updated the module, read the release notes and README files and review the isseu queue for related threads. If you still have a specific issue, you'll need to provide more details than just lists aren't showing up.

Had the same error. Updated from 2.7 to 2.9, After fixing the MCAPI library error, I tried to make a new list, but could not find any existing lists in MailChimp. My API key was correct, and I tried to refresh the lists, but could not figure out why it was not retrieving the lists from MailChimp. I even uninstalled MailChimp and reinstalled to no avail.

I had to go back to 2.7, which works, until someone can figure out why this is happening.

AyyItsDave, thank you for the suggestion. Indeed, I rolled back MailChimp to 2.7 and that fixed the problem.