The installation fails throwing up the error below .. While searching around, I discovered that a a similar issue had been flagged for nodestream 7.x-2.0-alpha11, for which a patch (http://drupal.org/files/media-install-error-1311828-28.patch) had been applied.

However, looking at this patch, and the code itself, the patch is already in place within the code .. So, this is a separate issue .. Will keep trying to track it down

It is worth noting that I enabled every single option during the install ..

### full error message follows #############
An AJAX HTTP error occurred. HTTP Result Code: 200 Debugging information follows. Path: http://localhost/nsfull/install.php?profile=nodestream&locale=en&id=2&op=do StatusText: OK ResponseText: Home | Nodestream Full @import url("http://localhost/nsfull/modules/system/system.theme.css?mgkgfj"); @import url("http://localhost/nsfull/modules/system/system.messages.css?mgkgfj"); @import url("http://localhost/nsfull/modules/system/system.menus.css?mgkgfj"); @import url("http://localhost/nsfull/modules/system/system.base.css?mgkgfj"); @import url("http://localhost/nsfull/modules/field/theme/field.css?mgkgfj"); @import url("http://localhost/nsfull/modules/node/node.css?mgkgfj"); @import url("http://localhost/nsfull/modules/user/user.css?mgkgfj"); @import url("http://localhost/nsfull/profiles/nodestream/modules/contrib/views/css/vi..."); @import url("http://localhost/nsfull/modules/system/system.admin.css?mgkgfj"); @import url("http://localhost/nsfull/modules/system/system.maintenance.css?mgkgfj"); @import url("http://localhost/nsfull/profiles/nodestream/modules/contrib/ctools/css/c..."); @import url("http://localhost/nsfull/profiles/nodestream/modules/contrib/panels/css/p..."); @import url("http://localhost/nsfull/themes/seven/reset.css?mgkgfj"); @import url("http://localhost/nsfull/themes/seven/style.css?mgkgfj"); Home Installation tasksChoose profile(done)Choose language(done)Verify requirements(done)Set up database(done)Install profile(done)Configure site(done)Configure NodeStream(done)Install NodeStream features(active)Apply configurationFinished SQLSTATE[42S02]: Base table or view not found: 1146 Table 'nsfull.media_type' doesn't exist

Comments

Sorry, I got that mixed up ..

I initially installed the patch http://drupal.org/files/media-n1311828.patch (and NOT http://drupal.org/files/media-install-error-1311828-28.patch) as I posted earlier in this issue.

The later patch had no relevance in my case as the file to be patched was not even in my nodestream tree, and seemed to apply to a media module plugin rather than media module itself ..

After applying that I patch, I used the back button of my browser to navigate back, unchecked the media option and submitted again .. Now, I get the ERROR below .. going back on the browser again and enabling the media module, still yields only the error message below .. suggesting that the patch media-n1311828 had fixed the initial media_type issue:

================= ERROR ==============
Warning: Invalid argument supplied for foreach() in file_entity_field_extra_fields() (line 432 of /var/www/nodestream/profiles/nodestream/modules/contrib/file_entity/file_entity.module).

SQLSTATE[42S02]: Base table or view not found: 1146 Table 'nsfull.media_type' doesn't exist ..
================= END ERROR ====================

UPDATE:

I followed some discussions about profile installation, and core registry, and ended up applying the patch described here: http://drupal.org/files/patch-to-module_enable-for-profile-installation_... .. then dropped the DB, and restarted install ..

I also retained the ealier patch I had applied: http://drupal.org/files/media-n1311828.patch

This time, I once again enabled all features .. and all content types.

This time around, the install actually seems to reach its end .. as indicated by:

========== install success ? ========================
To use menu blocks, find the "Add menu block" link on the administer blocks page.

But right below the above display which had a green tick mark besides it, I also get:

============= error ====================
The installation encountered an error
Please continue to the error page

An AJAX HTTP request terminated abnormally. Debugging information follows. Path: http://localhost/nsfull/install.php?profile=nodestream&locale=en&id=3&op=do StatusText: ResponseText: ReadyState: 4
===============================================

I then opted to open the 'error page' in another tab of the browser, and surprisingly encountered no issues, and the re-assuring link to 'visit your site' was there .. Upon clicking the link, I get taken to the site, and there are no visible signs of anything not functioning well .. yet.

I have since used drush to run update and cron .. and everything still seems OK, even as quite a few modules were updated ..

So, it does seem as if the patch to module to enable profile installation might have been the main or a part of the issue ..