Documentation and issues reviewed:

Currently installed modules and libraries:

  • Drupal 7.19
  • Libraries API 7.x-2.0
  • MailChimp 7.x-2.9 includes MailChimp and MailChimp_lists
  • MCAPI.class.php (MailChimp PHP API Wrapper 1.3) and README files installed in... /sites/all/libraries/mailchimp. (Examples folder was removed.)
  • Entity API 7.x-1.0 includes Entity API and Entity tokens

Installation and issues:

1. Enabled MailChimp, MailChimp Lists, Entity and Entity tokens at /admin/modules and Enabled all related Administrator permissions.

2. Checked tables in phpMyAdmin: Cache_mailchimp_user and mailchimp_lists were created.

3. At /admin/config/services/mailchimp entered a new API key generated in a MailChimp account that has existing lists and API keys. Left batch limit at default 100 and secure connection at default (on).

4. Went to /admin/config/services/mailchimp/lists and clicked "Refresh lists from MailChimp" and got "Mailchimp Lists refreshed". Clicked "Back to my lists". The existing MailChimp list was not listed.

5. Flushed all caches and ran cron and repeated. No available MailChimp lists appeared.

6. Attempted to "Add a List" at /admin/config/services/mailchimp/lists/add This failed because no available MailChimp lists appear in the pull down --Select-- menu under MailChimp List Settings. Got errors " MailChimp List field is required. The email merge field must be set to the user mail token."

Several variations on the above were tried. Tried new and existing API keys. Also shortened the name of the existing list on MailChimp since it exceeded 32 characters.

On the MailChimp.com website calls to the API reported for the associated account were zero in the last 24 hours. mailchimp_lists table is still empty.

At this point would like to confirm if something obvious has been overlooked.

Comments

Component:Lists» General
Category:support» bug
Priority:Normal» Major

Deleting /sites/all/modules/mailchimp/includes/mailchimp.inc file and replacing line 201 in mailchimp.module as suggested in #14 in 1314268 works. The existing list now appears and can be configured. The subscription block is also now available.

FWIW: the MailChimp account API key was-and-is on data center us2. Also this is a working site that is being upgraded from Drupal 6.9 and MailChimp 6.x-2.4.

I can also confirm that those two changes make the Mailchimp module work again (using v 7.x-2.9).

Priority:Major» Critical

I can confirm this bug as well. I updated my MailChimp module today that was functioning for months and after updating my lists were visible but I would receive error that my API key was not set (even though it certainly was) when attempting to update/subscribe to a list from the user page, also all of my list groups were missing, clicking the update lists works (could see the call in MC API log), but still lists not visible under the "MAILCHIMP LIST SETTINGS" section.

I followed suggestion #1 here (#14 in 1314268) and all of my lists are functioning properly again, the MailChimp module (version 7.x-2.9) is completely broken/nonfunctional as it currently stands when updating (I do not know if this issue appears on a fresh install)

Yep, I've just tried a fresh install with the same modules and nothing works.

Upgrading to the latest dev solved this for me.

Hi I tried to update to the latest version of the dev module even uninstalling the module and reactivating it and I still don't have my lists showing up. Let me know if you need any additional info. The library is successfully installed.

Cleared cache?

Hi yes I have cleared my cache multiple times and it still didn't work.

Hi yes I have cleared my cache multiple times and it still didn't work.

Hi yes I have cleared my cache multiple times and it still didn't work.

Confirmed that switching to -dev fixed the issue for me as well. Looks like they need to tag a new release...

Status:Active» Fixed

Status:Fixed» Closed (fixed)

Rolled into 7.x-2.10, thanks for the detailed bug reports here everyone. It turned out that this bug only appeared when the PHP global setting "arg_separator.output" was set to something other than "&": on all our test environments, it happened to be set to "&". The code has been changed to enforce this separator regardless of the setting in PHP.ini.

Version:7.x-2.9» 7.x-2.10
Status:Closed (fixed)» Active
StatusFileSize
new70.98 KB
new67.11 KB
new55 KB
new29.2 KB

Hi Sorry I just upgraded to the 7.x-2.10 version and I am still having the same problem.

I uninstalled the module and reactivated it.

I put in the API Key, then I when to refresh the list and I do not get any error it looks successful but when I go back to the mailing list screen it is empty. (please check the attached screen shots.)

I am running php 5.2.10-2ubuntu6. Attached is a screen shot showing my arg_separator.output setting.

I am using Drupal 7.18

Let me know what other info you need.

Status:Active» Closed (fixed)

This module does not import lists from MailChimp. Lists are Drupal entities mapped to MC lists. Please read through the docs (and other issues).

Status:Closed (fixed)» Postponed (maintainer needs more info)
StatusFileSize
new1.03 KB

deverman, sorry to hear you are still having this problem! Can you temporarily apply the patch attached here to your mailchimp 7.x-2.10 so I can have a better look at what's happening?

Just apply the patch, then go to /admin/config/services/mailchimp/lists and refresh your mailchimp lists, then go back to the lists page and it should give you some text output at the top of your page: paste that here.

Any chance you can test on a php 5.3 or 5.4 easily? If so, that could be informative.

For anyone reading: the attached patch has NO functionality improvements, it is purely to generate debugging info.

I have applied the patch. But now I think I may have misunderstood the interface.

When I refreshed the lists I thought they would show up in the list below the refresh list command.

Then I used the "Add a List" command and I saw my lists there.

then I was able to get to the merge fields after choosing the list.

So it seems that everything is actually OK but that the interface is a bit confusing.

Status:Postponed (maintainer needs more info)» Closed (works as designed)

Yep, the lists in Drupal vs lists in Mailchimp is a little confusing. Thanks for letting us know that everything is working!

I have drupal 7.2 installed with php 5.3, libraries 2.0, the mailchip library loaded. I can load and enable mailchimp and mailchimp lists. I refresh my lists and it says it has done it (no evidence that it has) when I hit new list or any other further action, I only get a white screen. Can anyone help? Thank you. been trying for 2 days now without luck.