I have a content type form which is exposed to users. It has shs in it and when i updated to 1.5 version now it's(shs) disappeared. Field title is till there, background color as well, there just no selection blocks. What's strange about it that everything is fine on admin side. Any ideas?

also i get this error:
Strict warning: Only variables should be passed by reference in shs_field_widget_form() (line 268 of C:\xampp\htdocs\gb\sites\all\modules\search_api\shs\shs.module).

,don't know if that's related.

I checked permissions, tried reinstalling, but it didn't help.

Files: 
CommentFileSizeAuthor
#4 Error106.75 KBMarcus VBP
#2 Manage fields.PNG71.76 KBStasko
#2 shsconfig1.PNG97.86 KBStasko
#2 shsconfig2.PNG86.32 KBStasko

Comments

Status:Active» Postponed (maintainer needs more info)

Hi.
Do you get any javascript errors when visiting the node form?
Could you post a screenshot of your field configuration ("Manage fields" tab) and of the configuration of the shs-field?

StatusFileSize
new86.32 KB
new97.86 KB
new71.76 KB

I don't get any errors apart from the mentioned one.

Also, it's very strange, but everything is fine with 1.3 version of shs.

Which version of PHP are you running?
And did you really install the module into the module directory of "Search API"?

StatusFileSize
new106.75 KB

Hi,

I'm getting the same error:

Strict warning: Only variables should be passed by reference em shs_field_widget_form() (linha 268 de /home2/enpegtwo/public_html/enpeg2013/sites/all/modules/shs/shs.module).

I attached a screenshot of the field configuration.

You can view the error in the following page: http://enpeg2013.com.br/user/register (please, don't create a new account).

Drupal: 7.19
PHP: 5.4.10
Jquery Update: jQuery 1.5.2 and jQuery UI 1.8.11

Thank You

Ah, PHP5.4 might be the hint I've searched for.
@Stasko: I guess you're running your site on PHP5.4 too?

I've committed a small change that fixes the warning from PHP.

Back to the original problem ... Stasko: did you install other modules which modify the node form (alter fields, adding javascript, etc.)?

You're right, it was PHP 5.4!

I just installed modules that add additional fields, but do not change current ones. I'll check on that to be 100% sure!

Also, as i mentioned, everything works on 1.3 version, any idea what changes you've made might be causing it?

Status:Postponed (maintainer needs more info)» Fixed

After installing newest dev version everything works perfectly!

Really appreciate your help! Thank you.

Status:Fixed» Closed (fixed)

Automatically closed -- issue fixed for 2 weeks with no activity.

Just updated to newest dev version and again i get the same issue, just this time i can't see selection fields on admin end as well.

Status:Closed (fixed)» Active

Version:7.x-1.5» 7.x-1.x-dev

Hi.
Could you please provide some more details about the field, the vocabulary, ... anything which helps me to reproduce this behavior.
I've updated the module right now on a customer site and it works without any problems.

Status:Active» Closed (cannot reproduce)

Fee free to reopen with some more details if the problem still exists.

Issue summary:View changes

update