Hi...

I am setting up a site for a entertainment agency. So there is a page called "search our acts" that is a view, using a hidden filter for content type "act". It uses the lightbox trigger field to display a bigger photo and some content about each act when clicking on their thumbnail image. The view also uses 4 exposed filters all but one of which seem to work. The one that doesn't work is on a content taxonomy field titled gender.

When you using the exposed filter "gender" and selecting "male" or "female", the wrong information is shown for what is set to display in the popup. The caption strangely is correct.

I have made the change described here: http://drupal.org/node/770718#comment-3050902 ... I tested using a pager afterwards and that seems to work ok. The exposed filter "gender" still causes problems though... I also upgraded to the dev version of lightbox2 having realised i need it because I'm using the jquery update module. I also tried switching to the Garland theme and that did not change anything.

I also loaded the popup information in a custom field to display the information i.e. without clicking the image. The correct information was shown except in the popup's...

Also if you don't select anything for "Gender" all the correct information is shown. If you select a "gender" with another exposed filter, everything works. But if you select a gender by itself everything goes wrong where the lightbox popup is concerned. If you use any combination of the other filters, without selecting anything for "gender" everything seems to be fine...

I would love any advice that anyone can give me. If any more info is needed then let me know.

Many thanks,

Guy

p.s you can view the strange goings on here: http://agency.onlinebusinessbuilders.co.uk/search-entertainment-acts

Comments

I probably should also have mentioned what versions of things I'm using:

  • Lightbox2: 6.x-1.x-dev
  • Views: 6.x-2.16
  • Imagecache: 6.x-2.0-beta12
  • ContentTaxonomy: 6.x-1.0-rc2
  • JqueryUpdate: 6.x-2.0-alpha1
  • JqueryUI: 6.x-1.5
  • Content Construction Kit (CCK): 6.x-2.9

Just in-case it is relevant...

The three exposed filters, (Gender, Sexuality, services provided), are all using Content taxonomy. Each one has it's own vocabulary...

Actually there are quite a few combinations that don't work... Although there are quite a few that do...

Just tried using views 3 and views 3.dev... no luck on both accounts... Help! please...

I've now almost got it to work using this: http://drupal.org/node/770718#comment-3392314

Now i'm getting:

warning: urlencode() expects parameter 1 to be string, array given in \sites\all\modules\lightbox2\lightbox2_handler_field_lightbox2.inc on line 134.

Would sincerely appreciate any help or pointers...

Guy

For now, I've just turned off the "Print errors to screen" option....

Just noticed this morning that using (http://drupal.org/node/770718#comment-3392314) actually breaks things on the taxonomy pages... Doh! Nothing is displayed in the pop up...

Viewable here: http://agency.onlinebusinessbuilders.co.uk/taxonomy/term/4,24