The project page says "Some features require Node Comments 2.x.", which is what I'm using. However, that version is no longer supported. I was never quite sure whether this was because nodecomments v1 didn't work or whether nodecomments v3 didn't work.

Can us AF6 users update to the full supported nodecomment v3.0?

I'm a bit reluctant to try this myself, so thought I'd take the lazy way out and just ask.