I get the following error message during octopus o1 upgrade (up-stable) from BOA-2.0.5 to BOA-2.0.6:

Do you want to install some latest, ready to use platforms? [Y/n] n
Octopus [Tue Apr  2 22:45:05 BST 2013] ==> UPGRADE A: No new platforms added this time
Octopus [Tue Apr  2 22:45:07 BST 2013] ==> UPGRADE A: Cleaning up various dot files, please wait...
/opt/tmp/nginx-for-drupal/aegir/scripts/AegirSetupA.sh.txt: line 1168: cd: /data/all/004: No such file or directory
touch: cannot touch `/data/all/004/dot-files-ctrl-BOA-2.0.6': No such file or directory
Octopus [Tue Apr  2 22:45:12 BST 2013] ==> UPGRADE A: Adding symlink to the system clean_missing_modules
Octopus [Tue Apr  2 22:45:14 BST 2013] ==> UPGRADE A: Adding symlink to the system drush_ecl
ln: creating symbolic link `/home/o1.ftp/platforms/004/keys': No such file or directory
touch: cannot touch `/data/all/004/javascript_aggregator.out.txt': No such file or directory
Octopus [Tue Apr  2 22:45:16 BST 2013] ==> UPGRADE A: Preparing setupmail.txt
Files: 

Comments

Component:Code» Miscellaneous
Category:bug» support
Status:Active» Postponed (maintainer needs more info)

The error doesn't seem or appear to affect the operation of BOA. But created the issue as there was no such warning/error in earlier upgrades:

The warning lies in the following lines (included above)

/opt/tmp/nginx-for-drupal/aegir/scripts/AegirSetupA.sh.txt: line 1168: cd: /data/all/004: No such file or directory

touch: cannot touch `/data/all/004/dot-files-ctrl-BOA-2.0.6': No such file or directory

ln: creating symbolic link `/home/o1.ftp/platforms/004/keys': No such file or directory

touch: cannot touch `/data/all/004/javascript_aggregator.out.txt': No such file or directory

By "maintainer needs more info" I mean following (always) the guidelines.

You shouldn't see such errors, because it is a sign of something broken, like missing directories or out-of-sync settings etc.

server1:~# cat /data/disk/o1/log/octopus_log.txt
Wed Oct 31 12:06:44 CDT 2012 / Debian.squeeze x86_64 / Aegir HEAD / Octopus BOA-2.0.4-dev / FPM 5.3 / CLI 5.3
Fri Nov  9 16:30:03 GMT 2012 / Debian.squeeze x86_64 / Aegir BOA-2.0.4 / Octopus BOA-2.0.4 / FPM 5.3 / CLI 5.3
Sun Nov 11 10:52:50 GMT 2012 / Debian.squeeze x86_64 / Aegir BOA-2.0.4 / Octopus BOA-2.0.4 / FPM 5.3 / CLI 5.3
Sat Dec 29 00:35:11 GMT 2012 / Debian.squeeze x86_64 / Aegir BOA-2.0.5 / Octopus BOA-2.0.5 / FPM 5.3 / CLI 5.3
Tue Apr  2 22:45:18 BST 2013 / Debian.squeeze x86_64 / Aegir BOA-2.0.6 / Octopus BOA-2.0.6 / FPM 5.3 / CLI 5.3

server1:~# cat /var/aegir/config/includes/barracuda_log.txt
Wed Oct 31 11:42:30 CDT 2012 / Debian.squeeze x86_64 XEN / Aegir HEAD / Barracuda BOA-2.0.4-dev / Nginx 1.3.7 / PHP 5.2.17 and 5.3.18 / MODERN-YES / FPM 5.3 / CLI 5.3 / MariaDB-5.5.28 localhost / Wildcard YES
Fri Nov  9 15:11:35 GMT 2012 / Debian.squeeze x86_64 XEN / Aegir BOA-2.0.4 / Barracuda BOA-2.0.4 / Nginx 1.3.8 / PHP 5.2.17 and 5.3.18 / MODERN-YES / FPM 5.3 / CLI 5.3 / MariaDB-5.5.28 localhost / Wildcard YES
Sun Nov 11 10:47:27 GMT 2012 / Debian.squeeze x86_64 XEN / Aegir BOA-2.0.4 / Barracuda BOA-2.0.4 / Nginx 1.3.8 / PHP 5.2.17 and 5.3.18 / MODERN-YES / FPM 5.3 / CLI 5.3 / MariaDB-5.5.28 localhost / Wildcard YES
Fri Nov 30 09:29:30 GMT 2012 / Debian.squeeze x86_64 XEN / Aegir BOA-2.0.4 / Barracuda BOA-2.0.4 / Nginx 1.3.8 / PHP 5.2.17 and 5.3.18 / MODERN-YES / FPM 5.3 / CLI 5.3 / MariaDB-5.5.28a localhost / Wildcard YES
Fri Dec 28 23:50:37 GMT 2012 / Debian.squeeze x86_64 XEN / Aegir BOA-2.0.5 / Barracuda BOA-2.0.5 / Nginx 1.3.9 / PHP 5.2.17 and 5.3.20 / MODERN-YES / FPM 5.3 / CLI 5.3 / MariaDB-5.5.28a localhost / Wildcard YES
Mon Mar 11 21:12:15 GMT 2013 / Debian.squeeze x86_64 XEN / Aegir BOA-2.0.5 / Barracuda BOA-2.0.5 / Nginx 1.3.9 / PHP 5.2.17 and 5.3.20 / MODERN-YES / FPM 5.3 / CLI 5.3 / MariaDB-5.5.29 localhost / Wildcard YES
Fri Mar 29 19:15:17 GMT 2013 / Debian.squeeze x86_64 XEN / Aegir BOA-2.0.5 / Barracuda BOA-2.0.5 / Nginx 1.3.9 / PHP 5.2.17 and 5.3.20 / MODERN-YES / FPM 5.3 / CLI 5.3 / MariaDB-5.5.30 localhost / Wildcard YES
Tue Apr  2 22:32:38 BST 2013 / Debian.squeeze x86_64 XEN / Aegir BOA-2.0.6 / Barracuda BOA-2.0.6 / Nginx 1.3.15 / PHP 5.2.17 and 5.3.23 / MODERN-YES / FPM 5.3 / CLI 5.3 / MariaDB-5.5.30 localhost / Wildcard YES
server1:~#

server1:~# cat /root/.o1.octopus.cnf
###
### Configuration created on 121031-1143 with
### Octopus version BOA-2.0.4-dev
###
### NOTE: the group of settings displayed bellow
### will *override* all listed settings in the Octopus script.
###
_USER="o1"
_MY_EMAIL="myemail@gmail.com"
_PLATFORMS_LIST="ALL"
_ALLOW_UNSUPPORTED=NO
_AUTOPILOT=NO
_HM_ONLY=NO
_O_CONTRIB_UP=YES
_DEBUG_MODE=NO
_MY_OWNIP=
_FORCE_GIT_MIRROR=""
_THIS_DB_HOST=localhost
_DNS_SETUP_TEST=NO
_HOT_SAUCE=NO
_USE_CURRENT=YES
_REMOTE_CACHE_IP=127.0.0.1
_LOCAL_NETWORK_IP=
_PHP_FPM_VERSION=5.3
_PHP_CLI_VERSION=5.3
###
### NOTE: the group of settings displayed bellow will be *overriden*
### by config files stored in the /data/disk/o1/log/ directory,
### but only on upgrade.
###
_DOMAIN="o1.server1.domain.com"
_CLIENT_EMAIL="myemail@gmail.com"
_CLIENT_OPTION="SSD"
_CLIENT_SUBSCR="Y"
_CLIENT_CORES="8"
###
### Configuration created on 121031-1143 with
### Octopus version BOA-2.0.4-dev
###
_USE_STOCK=NO
_STRONG_PASSWORDS=NO
server1:~#

I upgraded octopus today using BOA2.0.7 and the following errors appeared while upgrading (I have already provided the requested info above):

Do you want to install some latest, ready to use platforms? [Y/n] n
Octopus [Thu Apr  4 13:32:39 BST 2013] ==> UPGRADE A: No new platforms added this time
Octopus [Thu Apr  4 13:32:41 BST 2013] ==> UPGRADE A: Cleaning up various dot files, please wait...
/opt/tmp/nginx-for-drupal/aegir/scripts/AegirSetupA.sh.txt: line 1168: cd: /data/all/004: No such file or directory
touch: cannot touch `/data/all/004/dot-files-ctrl-BOA-2.0.7': No such file or directory
ln: creating symbolic link `/home/o1.ftp/platforms/004/keys': No such file or directory
touch: cannot touch `/data/all/004/javascript_aggregator.out.txt': No such file or directory
Octopus [Thu Apr  4 13:33:00 BST 2013] ==> UPGRADE A: Preparing setupmail.txt

Please:

1. Enable debugging, as explained in the guidelines.
2. Attach *complete* log, not just a snippet.
3. Provide a result of commands listed below:

ls -l /data/all/
ls -l /data/all/*/ | grep o_contrib
ls -l /data/disk/o1/distro/
ls -l /home/o1.ftp/platforms/
ls -l /data/disk/o1/platforms/ | grep pressflow

Well after enabling _DEBUG_MODE=YES and forcing the the aegir and platform upgrade the content of cat /data/disk/o1/log/octopus_log.txt remains the same. Also the I was unable to install Panopoly-rc4a in the first attempt during upgrade- it complained about panopoly related stuff not found in /data/all/004 etc. During second attempt -force upgrade with _DEBUG_MODE=YES- it did not even ask for panapoly install, see below:

Octopus [Fri Apr  5 22:18:35 BST 2013] ==> UPGRADE B: Hostmaster STATUS: upgrade completed
Octopus [Fri Apr  5 22:18:35 BST 2013] ==> UPGRADE B: Simple check if Aegir upgrade is successful
Octopus [Fri Apr  5 22:18:37 BST 2013] ==> UPGRADE B: Aegir upgrade test result: OK
Octopus [Fri Apr  5 22:18:37 BST 2013] ==> UPGRADE B: Enhancing Aegir UI, please wait...
Octopus [Fri Apr  5 22:19:45 BST 2013] ==> UPGRADE A: Aegir Satellite Instance upgrade completed
Do you want to install some latest, ready to use platforms? [Y/n] y
Octopus [Fri Apr  5 22:20:52 BST 2013] ==> UPGRADE A: Creating shared directories, please wait...
Octopus [Fri Apr  5 22:20:53 BST 2013] ==> UPGRADE A: Running o_contrib modules check and upgrade, please wait...
Octopus [Fri Apr  5 22:20:53 BST 2013] ==> UPGRADE A: Switching user and running Platforms build
Octopus [Fri Apr  5 22:20:55 BST 2013] ==> INIT C: Aegir automated install script part C
Octopus [Fri Apr  5 22:20:55 BST 2013] ==> UPGRADE C: Shared platforms code v.004 (latest available) will be used for this install
Acquia 6.28.1 P.004 - http://bit.ly/acquiadrupal [Y/n] n
Octopus [Fri Apr  5 22:20:58 BST 2013] ==> DISTRO: Acquia 6.28.1 P.004 installation skipped
CiviCRM 4.1.6 6.28.1 P.004 - http://civicrm.org [Y/n] n
Octopus [Fri Apr  5 22:21:01 BST 2013] ==> DISTRO: CiviCRM 4.1.6 6.28.1 P.004 installation skipped
CiviCRM 4.2.8 7.22.1 P.004 - http://civicrm.org [Y/n] n
Octopus [Fri Apr  5 22:21:04 BST 2013] ==> DISTRO: CiviCRM 4.2.8 7.22.1 P.004 installation skipped
Conference 1.0-rc2 6.28.1 P.004 - http://usecod.com [Y/n] n
Octopus [Fri Apr  5 22:21:07 BST 2013] ==> DISTRO: Conference 1.0-rc2 6.28.1 P.004 installation skipped
Commerce 1.16 7.22.1 P.004 - http://drupalcommerce.org [Y/n] n
Octopus [Fri Apr  5 22:21:11 BST 2013] ==> DISTRO: Commerce 1.16 7.22.1 P.004 installation skipped
Commons 2.12 6.28.1 P.004 - http://acquia.com/drupalcommons [Y/n] n
Octopus [Fri Apr  5 22:21:14 BST 2013] ==> DISTRO: Commons 2.12 6.28.1 P.004 installation skipped
Drupal 6.28.1 P.004 - http://pressflow.org [Y/n] n
Octopus [Fri Apr  5 22:21:17 BST 2013] ==> DISTRO: Drupal 6.28.1 P.004 installation skipped
Drupal 7.22.1 P.004 - http://drupal.org/drupal-7.22 [Y/n] n
Octopus [Fri Apr  5 22:21:20 BST 2013] ==> DISTRO: Drupal 7.22.1 P.004 installation skipped
MNews 1.2.3 6.28.1 P.004 - http://managingnews.com [Y/n] n
Octopus [Fri Apr  5 22:21:23 BST 2013] ==> DISTRO: MNews 1.2.3 6.28.1 P.004 installation skipped
Open Atrium 1.7.1 6.28.1 P.004 - http://openatrium.com [Y/n] n
Octopus [Fri Apr  5 22:21:26 BST 2013] ==> DISTRO: Open Atrium 1.7.1 6.28.1 P.004 installation skipped
OpenChurch 1.11-b9 7.22.1 P.004 - http://openchurchsite.com [Y/n] n
Octopus [Fri Apr  5 22:21:29 BST 2013] ==> DISTRO: OpenChurch 1.11-b9 7.22.1 P.004 installation skipped
Open Outreach 1.0-rc10 7.22.1 P.004 - http://openoutreach.org [Y/n] n
Octopus [Fri Apr  5 22:21:32 BST 2013] ==> DISTRO: Open Outreach 1.0-rc10 7.22.1 P.004 installation skipped
Prosepoint 0.46 6.28.1 P.004 - http://prosepoint.org [Y/n] n
Octopus [Fri Apr  5 22:21:35 BST 2013] ==> DISTRO: Prosepoint 0.46 6.28.1 P.004 installation skipped
Ubercart 2.11.1 6.28.1 P.004 - http://ubercart.org [Y/n] n
Octopus [Fri Apr  5 22:21:48 BST 2013] ==> DISTRO: Ubercart 2.11.1 6.28.1 P.004 installation skipped
Ubercart 3.4.1 7.22.1 P.004 - http://ubercart.org [Y/n] n
Octopus [Fri Apr  5 22:21:52 BST 2013] ==> DISTRO: Ubercart 3.4.1 7.22.1 P.004 installation skipped
Octopus [Fri Apr  5 22:21:54 BST 2013] ==> UPGRADE C: Removing some old core themes, please wait...
Octopus [Fri Apr  5 22:21:54 BST 2013] ==> UPGRADE C: Running Platforms Save & Verify tasks, please wait...
Octopus [Fri Apr  5 22:22:01 BST 2013] ==> UPGRADE A: Platforms installation completed
Octopus [Fri Apr  5 22:22:01 BST 2013] ==> UPGRADE A: Creating ftp symlinks
Octopus [Fri Apr  5 22:22:03 BST 2013] ==> UPGRADE A: Preparing setupmail.txt
Octopus [Fri Apr  5 22:22:06 BST 2013] ==> UPGRADE A: Resending setup e-mail on upgrade, please wait...
Octopus [Fri Apr  5 22:22:08 BST 2013] ==> UPGRADE A: New entry added to /data/disk/o1/log/octopus_log.txt
Octopus [Fri Apr  5 22:22:08 BST 2013] ==> UPGRADE A: Final cleaning, please wait a moment...
Octopus [Fri Apr  5 22:22:13 BST 2013] ==> UPGRADE A: Starting the cron now
Octopus [Fri Apr  5 22:22:13 BST 2013] ==> UPGRADE A: All done!
Octopus [Fri Apr  5 22:22:13 BST 2013] ==> BYE!
Done for /data/disk/o1
OCTOPUS upgrade completed
Bye

The verification task log for panopoly-rc4a is:

Submitted by admin on Fri, 04/05/2013 - 21:21
Platform: Panopoly 1.0-rc4a 7.22.1 P.004
Status: Failed
Executed: Fri, 04/05/2013 - 21:46
Execution time: 1 sec
Log message
Task starts processing
Running: /data/disk/o1/tools/drush/drush.php --context_type='platform' --master_url='http://o1.sub.aegir.local/' --root='/data/disk/o1/distro/004/panopoly-7.x-1.0-rc4-7.22.1' --server='@server_master' --web_server='@server_master' --make_working_copy='null' provision-save '@' --backend 2>&1
Bootstrap to phase 0.
Drush bootstrap phase : _drush_bootstrap_drush()
Bootstrap to phase 0.
Found command: provision-save (commandfile=provision)
Initializing drush commandfile: db
Initializing drush commandfile: dns
Initializing drush commandfile: drush_make
Initializing drush commandfile: drush_make_d_o
Initializing drush commandfile: example
Initializing drush commandfile: http
Initializing drush commandfile: provision
Load alias @self
Load alias @server_master
Loading nginx driver for the http service
Loading nginx driver for the cdn service
Initializing drush commandfile: provision_cdn
Initializing drush commandfile: provision_civicrm
Load alias @
Template loaded: /data/disk/o1/.drush/provision/Provision/Config/Drushrc/provision_drushrc_alias.tpl.php
Generated config Drush configuration file
Changed permissions of /data/disk/o1/.drush/.alias.drushrc.php to 440
Command dispatch complete
Peak memory usage was 11.46 MB
Running: /data/disk/o1/tools/drush/drush.php @ provision-verify --backend 2>&1
Bootstrap to phase 0.
Drush bootstrap phase : _drush_bootstrap_drush()
Load alias @
Bootstrap to phase 5.
Drush bootstrap phase : _drush_bootstrap_drupal_root()
Loading drushrc "/data/disk/o1/aegir/distro/007/drushrc.php" into "drupal" scope.
Initialized Drupal 6.28 root directory at /data/disk/o1/aegir/distro/007
The drush command '@ provision-verify' could not be found.
Could not find a Drupal settings.php file at ./sites/default/settings.php.
Changes made in drush_hosting_task have been rolled back.
Command dispatch complete
Peak memory usage was 29.7 MB

Apart from above I was not able to detect any error during the forced upgrade (with _DEBUG_MODE=YES

The output of your commands in #6 are

aegir:~# ls -l /data/all/
total 20K
drwx--x--x  4 root root 4.0K Apr  5 00:45 000/
drwx--x--x 15 root root 4.0K Nov 22 22:19 001/
drwx--x--x  6 root root 4.0K Mar 24 20:42 002/
drwx--x--x  9 root root 4.0K Mar 24 21:56 003/
drwx--x--x 18 root root 4.0K Apr  5 00:45 004/

aegir:~# ls -l /data/all/*/ | grep o_contrib
drwxr-xr-x 27 root root  4.0K Mar 24 21:56 o_contrib/
drwxr-xr-x 28 root root  4.0K Mar 24 21:56 o_contrib_seven/
drwxr-xr-x 28 root root  4.0K Mar 24 21:56 o_contrib/
drwxr-xr-x 29 root root  4.0K Mar 24 21:56 o_contrib_seven/
drwxr-xr-x 28 root root  4.0K Mar 24 21:45 o_contrib/
drwxr-xr-x 29 root root  4.0K Mar 24 21:45 o_contrib_seven/
drwxr-xr-x 28 root root  4.0K Apr  5 00:31 o_contrib/
drwxr-xr-x 29 root root  4.0K Apr  5 00:31 o_contrib_seven/
aegir:~#

aegir:~# ls -l /data/disk/o1/distro/
total 28K
drwx--x--x  4 o1 users 4.0K Mar 24 22:35 001/
drwx--x--x  3 o1 users 4.0K Mar 24 22:24 002/
drwx--x--x  8 o1 users 4.0K Mar 24 21:55 003/
drwx--x--x 10 o1 users 4.0K Apr  5 00:41 004/
drwx--x--x  2 o1 users 4.0K Mar 28 10:06 005/
drwx--x--x  2 o1 users 4.0K Apr  5 00:27 006/
drwx--x--x  2 o1 users 4.0K Apr  5 22:16 007/
aegir:~#

aegir:~# ls -l /home/o1.ftp/platforms/
total 16K
drwxr-xr-x 2 o1 users 4.0K Mar 24 22:40 001/
drwxr-xr-x 2 o1 users 4.0K Mar 24 22:25 002/
drwxr-xr-x 2 o1 users 4.0K Mar 24 21:55 003/
drwxr-xr-x 2 o1 users 4.0K Apr  5 00:45 004/
aegir:~#

aegir:~# ls -l /data/disk/o1/platforms/ | grep pressflow
aegir:~#

Since there is nothing in
/data/disk/o1/log/octopus_log.txt
/var/aegir/config/includes/barracuda_log.txt

Is there some where else I can look for logs.

StatusFileSize
new55.77 KB

I am attaching the visible part of the terminal output during the last (forced and DEBUG_MODE=YES) upgrade. It is not complete but it is about 90% of it.

Status:Postponed (maintainer needs more info)» Active

Thanks, but, well, if you have said n to all questions, no new structure has been created there, hence these weird errors, because it is not intended to be "used" that way (by skipping all platforms). Why do you fire up adding platforms at all if you skip them all? You should just set _HM_ONLY=YES in the /root/.o1.octopus.cnf and never see these questions. Or you are giving us confusing logs instead of those with errors.

As for the Panopoly issue - if you see something like provision-save '@' --backend then something is already terribly wrong with this Aegir instance and I have no idea how to help further without checking the system personally, but we don't have anyone available for such investigation in the next few days.

A quick hint:

1. Delete /data/disk/o1/distro/004/panopoly-7.x-1.0-rc4-7.22.1 directory **and** corresponding failed node in Aegir.

2. Delete /data/all/004/panopoly-7.x-1.0-rc4-7.21.2 directory (if exists)

3. Run upgrade again.

Note that Panopoly is build from makefile and if Drupal.org is terribly slow or crashes as it did today, the build will fail.

StatusFileSize
new190.47 KB
new178.54 KB

Since the installation was on a virtualbox vm (as was testing upgrade) I restored the the VM (using snapshot) to the pre-BOA2.0.6 (state) and ran the upgrade again. This time I have captured the entire barracuda and octopus intall terminal messages (with _DEBUG_MODE=YES). In octopus_.log.txt you can see that it is only panopoly-rc4a distro which fails to install (and will subsequently give verify errors -pertaining to @ provision-verify). There may be other errors in the attached files. You can see that in above posts I have mentioned errors regarding /data/disk/all/004 directory.

I think I did nothing else on this aegir instance except experimenting with building custom panopoly platform from git, adding modules to it and then trying to install sites on it. Installing customisted site with new modules was always a faliure. I think panopoly is a very picky/choosy/sensitive distro which is either not suitable for drush 4 (in vanilla state downloaded directly and not patched) or it doesn't like customisation without involving extensive developer level patching.

Complete files attached.

Status:Active» Closed (cannot reproduce)

We have tested this many times on various systems, on upgrades and clean installs, even on major upgrade from some old Lenny VM image with almost two year old install and it just works, so it seems like something specific to your system, because we couldn't reproduce this. Please try on a clean install, since maybe there are some mods you did and are not aware of etc.

Note, that this has nothing to do with Panopoly being 'fragile' itself, as installing the platform just works, and BOA of course uses Drush 5 for this task.

The error mentioned in #1 above is appearing again in a rackspace live server upon upgrade to BOA2.0.8. This time I have not installed any platforms. If I would have tried to install any new platform it would have given panopoly error. Please not that the server used in this post (#14) is a different server than used in #12 above but is same as #1 above. Both complain of platform files in 004 (confusing)

Do you want to install some latest, ready to use platforms? [Y/n] n
Octopus [Mon Apr  8 16:32:11 BST 2013] ==> UPGRADE A: No new platforms added this time
Octopus [Mon Apr  8 16:32:13 BST 2013] ==> UPGRADE A: Cleaning up various dot files, please wait...
/opt/tmp/nginx-for-drupal/aegir/scripts/AegirSetupA.sh.txt: line 1168: cd: /data/all/004: No such file or directory
touch: cannot touch `/data/all/004/dot-files-ctrl-BOA-2.0.8': No such file or directory
ln: creating symbolic link `/home/o1.ftp/platforms/004/keys': No such file or directory
touch: cannot touch `/data/all/004/javascript_aggregator.out.txt': No such file or directory
Octopus [Mon Apr  8 16:32:18 BST 2013] ==> UPGRADE A: Preparing setupmail.txt
Octopus [Mon Apr  8 16:32:20 BST 2013] ==> UPGRADE A: New entry added to /data/disk/o1/log/octopus_log.txt
Octopus [Mon Apr  8 16:32:20 BST 2013] ==> UPGRADE A: Final cleaning, please wait a moment...
Octopus [Mon Apr  8 16:32:28 BST 2013] ==> UPGRADE A: Starting the cron now
Octopus [Mon Apr  8 16:32:28 BST 2013] ==> UPGRADE A: All done!
Octopus [Mon Apr  8 16:32:28 BST 2013] ==> BYE!
Done for /data/disk/o1
OCTOPUS upgrade completed
Bye

Since this is a live server some hints on fixing this would be very welcome. Can I do something similar to #10 above like deleting 004 files/directory and upgrading again.

Just to clarify that server in #1 (the live server) is different than server in #12 (virtualbox vm) an posts other than #1. After the error mention in #1 occurred ,I did not try platform upgrade on live server and went on to do the testing in a similar virtualbox local vm (which also gave similar errors). I feared spoiling my live server to so tested it in VM. Both these servers were upgraded from BOA-2.0.5. The error in #1 or #12 only occurs in upgrades from BOA-2.0.5. I freshly installed a server from BOA-2.0.6 and the upgraded to 2.0.7 and then to 2.0.8 and there were no errors.