Hi!

On March 28. „ColorBox” renamed to „Colorbox” in branch 1.x, but in hook_libraries_info() the plugin pattern still @ColorBox v([0-9\.a-z]+)@ in colorbox.module:

<?php
...
/**
* Implements hook_libraries_info().
*/
function colorbox_libraries_info() {
 
$libraries['colorbox'] = array(
   
'name' => 'Colorbox plugin',
   
'vendor url' => 'http://www.jacklmoore.com/colorbox',
   
'download url' => 'http://www.jacklmoore.com/colorbox',
   
'version arguments' => array(
     
'file' => 'jquery.colorbox-min.js',
     
'pattern' => '@ColorBox v([0-9\.a-z]+)@',
     
'lines' => 5,
    ),
   
'files' => array(
     
'js' => array(
       
'jquery.colorbox-min.js',
      ),
    ),
   
'variants' => array(
     
'minified' => array(
       
'files' => array(
         
'js' => array(
           
'jquery.colorbox-min.js',
          ),
        ),
      ),
     
'source' => array(
       
'files' => array(
         
'js' => array(
           
'jquery.colorbox.js',
          ),
        ),
      ),
    ),
  );
  return
$libraries;
}
...
?>

So colorbox.module doesn't work with plugin version v.1.4.6 or higher.

Comments

Status:Active» Closed (duplicate)