Because this has evolved to more than just a file formatter, the current naming no longer reflects the true functionality of the module.

As a result, I'd suggest a name change (and move) to 'File Field Enhancements'.

Not only is this more accurate (and more likely to be found by someone looking for the file upload widget enhancements), it can also serve as a home for other enhancements we'd like to incorporate on drupal.org ... for example, merging in with http://drupal.org/project/files_undo_remove may be desirable.

Remaining tasks

  1. Fix the project node at https://drupal.org/sandbox/jthorson/1964794
  2. Promote that sandbox to a full project
  3. Move all the issues in this queue into the new project's queue
  4. Mark this project node abandoned/obsolete
  5. #1954454: Use extended_file_field for issue node file fields for d.o D7 port

Comments

dww’s picture

Status: Active » Reviewed & tested by the community

+1

Do you want to just create a new project node, and then push all the commits from here into the new Git repo, rename the module and all the files in that new repo, and then mark this project obsolete/abandoned? Or do you have another plan in mind? Lemme know how you want to proceed.

Thanks!
-Derek

dww’s picture

Status: Reviewed & tested by the community » Needs review

Sanity check. We really want these:

hook_file_field_enhancements_metadata_types()
hook_file_field_enhancements_items_alter()
hook_file_field_enhancements_output_alter()
mymodule_file_field_enhancements_cid_formatter()

?

Probably the best we're going to come up with, and we don't have unlimited time, but if we're going to go through the trouble to rename this, it'd be nice to only do it once. ;)

Cheers,
-Derek

jthorson’s picture

Agreed. Other options?

ff_enhanced
filefield_tweaks
ff_tweaks
filefield_improved

jthorson’s picture

Issue tags: +project, +drupal.org D7

Tagging

dww’s picture

I prefer fieldfield over ff.

Maybe:

filefield_advanced

?

What about the modifier in front to further isolate us from possible namespace collisions with core? E.g.

advanced_filefield
extended_filefield
enhanced_filefield

?

dww’s picture

Title: Rename project and namespace to 'File Field Enhancements' » Rename project and namespace to 'Extended File Field'

Based on further IRC discussion, I think we're converging on:

extended_file_field

Any final objections?

Thanks!
-Derek

dww’s picture

Assigned: Unassigned » dww
Status: Needs review » Reviewed & tested by the community

https://drupal.org/sandbox/jthorson/1964794 now exists.

I'm going to work on pushing these commits into there and renaming the module later today. If I don't get to this before I have to leave for the evening I'll unassign myself again.

Once there's working code and we fix the project description, we can promote that to full, move all the issues out of this queue, and mark this project obsolete/abandoned.

Thanks,
-Derek

dww’s picture

Pushed the commits:
https://drupal.org/node/1964794/commits

Now I'll work on renaming everything.

dww’s picture

Assigned: dww » jthorson
Status: Reviewed & tested by the community » Needs review

Mostly went fine. A few lingering doubts:

hook_extended_file_field_metadata_types()

Do we still want think of this as the "metadata types" hook? I guess that's okay, even though metadata is no longer in the name of this module. It's still ultimately what the hook is about.

mymodule_extended_file_metadata_cid_formatter()

Is that a reasonable example name for this callback? Didn't seem like "mymodule_extended_file_field_metadata_cid_formatter()" was necessary, but it'd technically be more consistent that way.

There are a few Field API hooks that start with the word "field", so our module ending in the word "field" results in function names like:

extended_file_field_field_formatter_info()
extended_file_field_field_formatter_settings_summary()

etc. Slightly unfortunate, but I think it's fine.

Otherwise, this all seems to be working again on my local test site. I split it up into two commits to hopefully make it easier to follow WTF happened. The first is a pure 'git mv' on the 4 filenames:

http://drupalcode.org/sandbox/jthorson/1964794.git/commit/bdbd42d

The second is the actual code/docs changes:

http://drupalcode.org/sandbox/jthorson/1964794.git/commit/7096390

Once we resolve the above questions and get the project node happy, we can promote, move issues, fix up the d.o BZR tree, etc.

Thanks!
-Derek

jthorson’s picture

hook_extended_file_field_metadata_types()
The examples came from the first iteration of this code, where the sole purpose of the module was to add metadata to the table. Perhaps a change to 'hook_extended_file_field_columns()'?

mymodule_extended_file_metadata_cid_formatter()
As above, part of the first iteration ... I'd suggest 'mymodule_extended_file_field_cid_formatter()'.

dww’s picture

Status: Needs review » Needs work

Split the first off into a separate issue: #1964926: Rename hooks from "metadata" to "columns"

Agreed on the 2nd:
http://drupalcode.org/sandbox/jthorson/1964794.git/commit/5f7213a

Put remaining tasks in the summary.

jthorson’s picture

Project: Attached Files Metadata Table » Extended File Field
jthorson’s picture

Issue summary: View changes

added list of remaining tasks

jthorson’s picture

Status: Needs work » Fixed
dww’s picture

Yay, thanks!

jthorson’s picture

Assigned: jthorson » Unassigned

Automatically closed -- issue fixed for 2 weeks with no activity.

Anonymous’s picture

Issue summary: View changes

Updated remaining tasks

  • Commit bdbd42d on 7.x-1.x, empty-file-2150029 by dww:
    [#1964092] by dww: Initial raw 'git mv' to extended_file_field namespace...
  • Commit 18dd32b on 7.x-1.x, empty-file-2150029 by dww:
    [#1964092] by dww: Fixed permssions on .module file.
    
  • Commit 7096390 on 7.x-1.x, empty-file-2150029 by dww:
    [#1964092] by dww: Renamed the module to extended_file_field.
    
  • Commit 5f7213a on 7.x-1.x, empty-file-2150029 by dww:
    [#1964092] by dww, jthorson: Followup doc cleanup for namespace rename.