The administrator role is required for panopoly_admin install but it seems the role is defined in panopoly_core, however panopoly_core is not a dependancy of panopoly_admin.

Comments

Here is a patch to check that the administrator role exists before it installs.
Other than this panopoly_core could be made a dependency of panopoly_admin, but you may not want that.

as a side note: how does panopoly know to install core before admin if its not a dependency?

Status:Active» Patch (to be ported)

Looks smart. Reviewed and committed to -dev.

As to your question, theoretically Panopoly X shouldn't require Panopoly Core. In practice this is not always true, but patches like this move us closer to that day :)

Status:Patch (to be ported)» Fixed

Committed

Status:Fixed» Closed (fixed)

Automatically closed -- issue fixed for 2 weeks with no activity.