I removed CAPTCHA and installed Mollom 6.x-2.4. It doesn't seem to be capturing anything. I am getting spam messages non-stop!!
I have added a form for comments, even increased the strictness to strict mode.
Does it take time to capture anything? what am I doing wrong?

Comments

Title:Mollom is not capturing any spam!Mollom is not capturing any spam
Status:Active» Postponed (maintainer needs more info)

1) Did you enter your Mollom API keys on the settings page?

2) Do you see any errors when visiting the settings page?

3) Are you sure that you protected the form that you wanted to protect?

4) Did you test as an anonymous user?

If a form is actively protected by Mollom Text analysis, then you should see the link to Mollom's privacy policy on the form.

1) Yes, I entered the Private and Public API keys

2) No errors

3) How can I protect the form? I just added a form and chose Comment. Is there anything else I should be doing?

4) Yes I did test as an anonymous user

Do you see Mollom's privacy policy link when visiting the form as an unprivileged user?

If not, you most likely did not protect the form (but a different one instead).

Note: The privacy policy link can be toggled in the global module settings.

Sorry for the late response. Since then I have uninstalled Mollom. I will re-install and check the option you mentioned. Thanks.

Status:Postponed (maintainer needs more info)» Closed (cannot reproduce)

It's been some time since the last update here. I'm going to close this ticket for now, as I hope that the issue is resolved.

Please feel free to reply if I'm mistaken or if you have additional questions.

Thanks for your feedback!