Hello,

My Pinterest window was blank when I clicked the "Pinit" button, so I added [node:field_image] to the Pinterest "media parameter" setting in Service Links admin. That causes the button to work properly when viewing an individual image node, but when I try to view a Views-driven gallery of image nodes I receive a very non-descript error message (" The website encountered an unexpected error. Please try again later. "). Any ideas on what I can do to fix this issue?

Thanks!

==============
EDIT: I just came across the fix in this comment: http://drupal.org/node/1411366#comment-6004310 . I'm not a big fan of hacking core, but it seems to have fixed my issue for now. Does anyone have any feedback on a safer, more permanent solution?

Files: 
CommentFileSizeAuthor
#1 service_links-1981474.patch1.02 KBTheCrow

Comments

Status:Active» Needs review
StatusFileSize
new1.02 KB

Let's try this

I was seeing #2007288: EntityMalformedException: Missing bundle property on entity of type node which is marked as a duplicate of this one. The patch here resolved it.

Status:Needs review» Fixed

Committed, thanks for review!

Status:Fixed» Closed (fixed)

Automatically closed -- issue fixed for 2 weeks with no activity.

I just encountered this exact problem. Mine is the fact that placing tokens here is very limiting. For example say for each content type I have a different image or description field that I want shown. Right now if I add a token for a specific content type and then view another node of a content type I get the error. I tried to add more than 1 token but that does not work either.

What can be done here?

Issue summary:View changes

more info