translation_entity implements hook_field_info_alter. However, there's also hook_entity_field_info_alter. In case translation is enabled (although it's hidden in D8), this hook is also seen as an implementation of the latter one for the translation module.

I ran into this because the module was enabled on my local machine and it leaked into a simpletest for the upgrade path ...


We'll probably want to rename translation_entity to translation once we are able to swap the latter out of core: #1952062: Remove legacy translation module in favor of content translation.

As we have lots of dependency on #1952062: Remove legacy translation module in favor of content translation, can't we use entity_translation for now? here is a patch which trying to do it #2024867: Rename translation_entity to content_translation

Status:Active» Closed (duplicate)

Issue tags:+language-content

Component:translation_entity.module» content_translation.module