It makes sense to rename the ViewsDataCache class to just ViewsData, it manages the views data, and just happens to use the cache backend and manage the getting/setting. So it's not just a cache it IS views data objectified :)

Also based on #1962234: [Change notice] Move views_fetch_fields into an autoloadable class I think that issue should use a class ViewsDataHelper.

Files: 
CommentFileSizeAuthor
#4 1989806-4.patch14.11 KBdamiankloip
PASSED: [[SimpleTest]]: [MySQL] 55,951 pass(es).
[ View ]
vdc.ViewsDataCache-rename.patch13.06 KBdamiankloip
FAILED: [[SimpleTest]]: [MySQL] Drupal installation failed.
[ View ]

Comments

Status:Needs review» Needs work
Issue tags:-VDC

The last submitted patch, vdc.ViewsDataCache-rename.patch, failed testing.

Status:Needs work» Needs review

vdc.ViewsDataCache-rename.patch queued for re-testing.

Status:Needs review» Needs work
Issue tags:+VDC

The last submitted patch, vdc.ViewsDataCache-rename.patch, failed testing.

Status:Needs work» Needs review
StatusFileSize
new14.11 KB
PASSED: [[SimpleTest]]: [MySQL] 55,951 pass(es).
[ View ]

Sorry, didn't include the actual changes to ViewsDataCache in the patch!!!

Status:Needs review» Reviewed & tested by the community

+++ b/core/modules/views/lib/Drupal/views/Tests/ViewsDataTest.phpundefined
@@ -8,7 +8,7 @@
-use Drupal\views\ViewsDataCache;
+use Drupal\views\ViewsData;

Just to be sure similar systems in core are named the following: ThemeRegistry, SchemaCache, ModuleInfo, AliasWhitelist. To sum it up, it would be more consistent to rename it.

+++ b/core/modules/views/lib/Drupal/views/Tests/ViewsDataTest.phpundefined
@@ -40,7 +40,7 @@ class ViewsDataTest extends ViewUnitTestBase {
-      'name' => 'Table Data',
+      'name' => 'Views data',

Yeah, this always confused me.

#4: 1989806-4.patch queued for re-testing.

Status:Reviewed & tested by the community» Fixed

Committed/pushed to 8.x, thanks!

Automatically closed -- issue fixed for 2 weeks with no activity.

Issue summary:View changes

Updated issue summary.