is there a way to change this string to the name of the website the post is shared from?

Comments

I changed the name of the App right now in FBShare by Service Links, if you want a custom app name apply the patch go to Adminster > Configuration > Service Links and switch to Widgets Tabs there are the info to build a custom Facebook App id for Facebook Share

StatusFileSize
new574 bytes

Here the patch

StatusFileSize
new15.79 KB

patch won't work:

This may be crucial to most of you, but it's the first time i'm applying a patch,
the .patch is in the same directory as the .module
this is the error i get from terminal:

Roel-iMac:service_links roelwelters$ patch < service_links-2000510.patch
can't find file to patch at input line 5
Perhaps you should have used the -p or --strip option?
The text leading up to this was:
--------------------------
|diff --git a/services/widget_services.admin.inc b/services/widget_services.admin.inc
|index 9248f87..39dc524 100644
|--- a/services/widget_services.admin.inc
|+++ b/services/widget_services.admin.inc
--------------------------
File to patch: service_links.module
patching file service_links.module
Hunk #1 FAILED at 130.
1 out of 1 hunk FAILED -- saving rejects to file service_links.module.rej

StatusFileSize
new455 bytes

i re-edited the patch, seems that the git diff patch is not welcome to patch command.

patch -p0 < service_links-2000510.patch

patched successfully!
now i can edit the app id, and i see the link to facebook.
However it is not very clear what to do on facebook, can you please point me in the right direction?
Kindest regards

StatusFileSize
new149.79 KB
  1. Click on "create app" button;
  2. fill the form giving a name to the app and a namespace not yet used;
  3. solve the captcha ;
  4. disable the sandbox mode and take note of the application ID in the upper part of the page;
  5. Save the modifies;
  6. Done!

Status:Active» Fixed

Patch committed if there are other troubles just continue here.

Title:Share link via FBShare TestShare link via FBShare Test - Links keep disappearing
Status:Fixed» Active

Hi,
now everytime i visit the site, the links are gone,
i have to log in,
go to admin/config/services/service-links
dont change anything, just press save
and the links are back.

Also the links are stacked, how do i put them on one line?

Kindest regards

Roel

is this related to anonymous user permissions? are you using some other social module?

here some suggestion to style the widgets links: http://servicelinks.altervista.org/?q=about/troubleshooting

StatusFileSize
new68.61 KB

I applied the patch
I made a facebook app
still the shared post says: Roel Welters heeft een link via FBShare by Service Links gedeeld.

you have to change the facebook app id in the service links configuration page... widgets tab... and go to facebook share settings

the patch is committed in dev so this should work without patch anymore if you have the latest dev

I did change the app id on the widgets tab, didnt work.
I'll start all over with the new dev version.

Is it better with the -dev version?