I'm getting a couple of errors when attempting to run the database update script after upgrading to 6.x-2.2. I saw a similar bug posted for 7.x, but wasn't sure if it was identical and if the supplied patches were appropriate:

  • Invalid argument supplied for foreach() in .../site/update.php on line 340.
  • array_merge(): Argument #2 is not an array in .../site/update.php on line 173.

Comments

i can't access to my pc but the error can be fixed adding a row in the update function like that (service_links.install):

<?php
function service_links_update_6200(&$sandbox) {
  ...
 
// Row to add
 
return array();
}
?>

Okay, thanks.

Version:6.x-2.2» 6.x-2.x-dev

Fixed in dev

Status:Active» Fixed

forgot the status

  1. When this happens, are the database updates actually run or not?
    • if not, how can I recover?
  2. When will this fix be actually released?

The installed version is Drupal 6.28.
If I should ask this elsewhere, please let me know where/how?

Using drupal 6 you may choice to unselect service links updates, they are not needed if you was using the branch 6.x-2.x already, otherwise apply the patch, i don't know when a new release will be available, maybe a 2.3-beta1 containing only the bug fixes could preceed the next 2.3.

Status:Fixed» Closed (fixed)

Automatically closed -- issue fixed for 2 weeks with no activity.