There's a few problems in the code that I'm fixing that I discovered. I will post a patch when I've fixed them.

Support from Acquia helps fund testing for Drupal Acquia logo

Comments

reubenavery’s picture

Also, the functions are all improperly namespaced (should be named permissions_api_* not permissions_*). Will fix this as well in my patch.

ebeyrent’s picture

I will not be changing the function names, unless there's a strong compelling reason for it. It would break a lot of existing code for very little gain.

Also, can you please be a bit more specific about the logic problems you alluded to?

reubenavery’s picture

Status: Active » Needs review
FileSize
4.08 KB

And here's the patch.

reubenavery’s picture

Re the function names, please see https://drupal.org/coding-standards#naming

reubenavery’s picture

My use case for this module consisted of two steps, both of which failed due to a number of defects:
drush perm-revoke --modules="foo" --all-roles
drush perm-grant --roles="foo,bar,quack" --permissions="allow failure"