Hi,

I've uploaded a screenshot here:

https://dl.dropboxusercontent.com/u/63070476/Screen%20Shot%202013-06-12%...

I have ticked all the service boxes just to show that the facebook like is not showing up for me. The gap in there should be a like button. This is on a localhost so that could be the reason. The source code of the page says:

[code]

  • Facebook Like
  • [/code]

    It's there, just not appearing on the page for some reason.

    I use context to place the block at the top of the page but none of the other widgets are affected, just the like button. I have tried all the combinations in:

    /admin/config/services/service-links

    and

    /admin/config/services/service-links/widgets

    but no like button.

    What else do you need in order to get to the bottom of this? Otherwise, I'm stumped.

    Comments

    After reading here:

    https://developers.facebook.com/docs/reference/plugins/like/

    I quote:

    "After July 2013 migration, the Like button required an absolute URL in the href parameter."

    I think this is why it's not showing up, I am testing on a local site, with url 'sitename:8888/etc/etc'

    you have to look the javascript file "facebook_like.js" if it is correctly loaded

    Yep, it's there on line 114 (minus tags so it shows up on this page):

    [code]
    type="text/javascript" src="http://ecoop:8888/sites/all/modules/service_links/js/facebook_like.js?mo..."
    [/code]

    Still not showing:

    https://dl.dropboxusercontent.com/u/63070476/service-links.png

    All there apart from like button.

    the only reason i can imagine is the javascript file, can you inspect your webpage with something like firebug? it should allows you to see if there are some error within the console and the source of the javascript itself (despite the html code is there doesn't mean that the javascript is loaded) also clean the cache for both your browser and your drupal installation in the case the browser is using the old cached version of facebook_like.js (that happens to me everytime with Firefox)

    When I add:

    iframe.service-links-facebook-like {
    display: block;
    background: yellow;
    }

    to my css, this happens:

    https://dl.dropboxusercontent.com/u/63070476/fbook_like_new.png

    I inspected with firebug and the element gets outlined like it's there on the page. The yellow box shows that it is there too, still unsure why the image is not appearing.

    do you have some javascript or ad blocker, or some antispy addon which blocks the facebook iframe?

    Hi, nothing like that running.

    I still don't know why this is happening. I can only think it's something to do with this being a local site. It does specify on the facebook developers page that the like button requires a full URL. This site is not ready so I can't test on a live server yet.

    Same problem here. Only started this week for no apparent reason on a live website. The javascript file loads properly. I have firebug installed and the markup which is not working is this:
    <iframe class="service-links-facebook-like" scrolling="no" frameborder="0" src="//www.facebook.com/plugins/like.php?href=www.example.com/node/4057&layout=button_count&show_faces=false&action=like&colorscheme=light&width=100&height=21&font=&locale=" allowtransparency="true" style="border: medium none; overflow: hidden; width: 100px; height: 21px;">
    If I fiddle with Firebug and change the markup to this:
    <iframe class="service-links-facebook-like" scrolling="no" frameborder="0" src="//www.facebook.com/plugins/like.php?href=https://www.example.com/node/4057&layout=button_count&show_faces=false&action=like&colorscheme=light&width=100&height=21&font=&locale=" allowtransparency="true" style="border: medium none; overflow: hidden; width: 100px; height: 21px;">
    then it works. So by simply adding https:// in the address of the src attribute.

    I was just looking at the various other issues, I think this one is the same problem as this one: #1400724: Facebook Like popup window doesn't show up . And my previous comment over here contradicts my suggestion at #1400724: Facebook Like popup window doesn't show up . So it seems that the problem in #1400724: Facebook Like popup window doesn't show up will remain after the July change on Facebook.

    I haven't had the chance to test it on a live site yet as I'm still working on it. I've actually just made a bunch of my own buttons with views and link module which link to the share pages on google plus, twitter and facebook. I would sometimes prefer using a module though as some people like the familiar buttons of these sites.

    Status:Active» Closed (duplicate)