I have a relatively simple site I'm trying to upgrade from a Drupal 6 custom platform to Drupal 7 custom platform. Both platforms have other sites working well on them.

I cloned the Drupal 6 site within the same custom platform and then disabled all contrib modules and uninstalled those modules that will no longer be used.

But when I go to migrate the site to the custom Drupal 7 platform it fails.

First I get these 2 errors:
Drush command terminated abnormally due to an unrecoverable error. Error: Class name must be a valid object or a string in /data/disk/wwmhosting-admin/static/wwm-site-starter-drupal-7-2.07/includes/common.inc, line 7797

Output from failed command : Fatal error: Class name must be a valid object or a string in /data/disk/wwmhosting-admin/static/wwm-site-starter-drupal-7-2.07/includes/common.inc on line 7797

And then I get 2 more errors (full text of errors attached). The first of these 2nd set of errors starts out:
Output from failed command : The following updates are pending: system module : 7000 - Rename blog and forum permissions to be consistent with other content types. 7001 - Generate a cron key and save it in the variables table. 7002 - Add a table to store blocked IP addresses. 7003 - Update {blocked_ips} with valid IP addresses from {access}. 7004 - Remove hardcoded numeric deltas from all blocks in core. 7005 - Remove throttle columns and variables. 7007 - Convert to new method of storing permissions. 7009 - Rename the variable for primary links. 7011 - Split the 'bypass node access' permission from 'administer nodes'. 7013 and continues like this until ending with
Do you wish to run all pending updates? (y/n): y

The second error of the 2nd set of errors starts out:
Drush was not able to start (bootstrap) the Drupal database. Hint: This error often occurs when Drush is trying to bootstrap a site that has not been installed or does not have a configured database. Drush was attempting to connect to : Drupal version : 7.22 Site URI : dev.2.kateripeaceconference.org Default theme : garland Administration theme: garland PHP configuration : /opt/local/lib/php.ini Drush version : 4.6-dev Drush configuration: /data/disk/wwmhosting-admin/static/wwm-site-starter-drupal-7-2.07/sites/dev.2.kateripeaceconference.org/drushrc.php /data/disk/wwmhosting-admin/static/wwm-site-starter-drupal-7-2.07/drushrc.php Drush alias files : /data/disk/wwmhosting-admin/.drush/dev.2.kateripeaceconference.org.alias.drushrc.php and it continues listing out every site on my system on every platform and then ends with
Drupal root : /data/disk/wwmhosting-admin/static/wwm-site-starter-drupal-7-2.07 Site path : sites/dev.2.kateripeaceconference.org Modules path : sites/dev.2.kateripeaceconference.org/modules Themes path : sites/dev.2.kateripeaceconference.org/themes File directory path: sites/dev.2.kateripeaceconference.org/files %paths : Array You can select another site with a working database setup by specifying the URI to use with the --uri parameter on the command line or $options['uri'] in your drushrc.php file.

Note that dev.2.kateripeaceconference.org is the site I'm trying to migrate and wwm-site-starter-drupal-7-2.07 is the custom platform I'm trying to migrate to.

If I migrate from my custom Drupal 6 platform to vanilla Drupal 7.22.1 D.016, the migration will occur, but with a bunch of errors like
WD system: The following module is missing from the file system: filefield. for each module that I have in the D6 site.
Along with these warnings:

Some user time zones have been emptied and need to be set to the correct values. Use the new time zone options to choose whether to remind users at login to set the correct time zone.
The default time zone has been set to America/New_York. Check the date and time configuration page to configure it correctly.

However, If I then try to migrate again to my custom platform, I get the same errors as if I tried to migrate directly from the D6 platform.

Also, I was able to successfully migrate without issue another Drupal 7 site on custom platform to this new Drupal 7 custom platform that I'm trying to migrate the D6 site to.

I don't know if this is an Aegir or BOA issue, or something I'm doing wrong. I've upgraded sites before from Drupal 6 custom platforms to Drupal 7 custom platforms without issue. I've tried searching for information regarding these errors all over the Drupal site and Aegir Community sites, but have not found anything to help me.

I've attached the full text of the of errors (hopefully they don't include anything that prevents a security risk by posting them here) as well as the octopus_log.txt, barracuda_log.txt and USER.octopus.cnf. However I did not do an upgrade of Octopus with _DEBUG_MODE=YES. If that is needed, just let me know.

Thanks in advance for any assistance you can give me and pointing me in the right direction!
Steve

Comments

Component:Aegir Hostmaster» Miscellaneous

This is really outside of the scope of both Aegir and BOA project, because Aegir is *designed to fail* if Drush reports any issues and we can't really guarantee that major upgrades will work, because Drupal itself is famous of not caring enough to provide *working* upgrade path.

However, you could at least try to:

1. Use non-dev site names
2. Disable Redis in the site before attempting migration and clear all caches.

Status:Active» Closed (won't fix)

Just realized I never came back and posted my results from using your suggestions. Neither of them worked. The site is still in D6 and I hope to explore other options later this week. This is probably one of the worst things about Drupal because if only the latest 2 versions will be supported it seems there should be a working upgrade path. But as you said, there isn't and this is discussion for another time and place.

Thanks anyways for your assistance, Omeg8cc, and all your totally awesome work!

Steve