Chosen have moved the subdirectory `chosen` to `public` in v0.10.0

This causes the following error during "Verify requirements" after using drush make:

Error Chosen JavaScript file Unavailable
Place chosen.jquery.min.js or chosen.jquery.js in sites/all/libraries/chosen/chosen.

Steps to reproduce:

  1. Goto http://simplytest.me/project/commerce_kickstart/7.x-2.8
  2. Click Launch sandbox.

Expected result:

Commerce Kickstart installs just fine.

Actual result:

Requirements problem

Related issue:

https://drupal.org/node/2021639

Files: 
CommentFileSizeAuthor
#1 chosen-version-fix-1-1.patch588 bytesd_inevitable

Comments

StatusFileSize
new588 bytes

Until the chosen module is fixed, this patch will fix commerce kickstart by explicitly using version 0.9.15.

In general it is better to point to fixed version tags when linking to external projects.

The patch does work but it is not included in the latest (July 8) version of commerce_kickstart

I had to manually apply the patch

Doesn't look like this fix was included in the July 8 dev version even though the commit says it was done on July 5. Are the packages broken?

Status:Fixed» Closed (fixed)

Automatically closed -- issue fixed for 2 weeks with no activity.