Hello,

i have installed the last dev version and get news warning errors :

    Strict warning : Declaration of FPDF::_putstream() should be compatible with TCPDF::_putstream($s, $n = 0) in require_once() (line 17 in /srv/data/web/vhosts/www.domain.fr/htdocs/sites/all/modules/views_pdf/views_pdf_template.php).
    Strict warning : Declaration of FPDF_TPL::SetFont() should be compatible with TCPDF::SetFont($family, $style = '', $size = NULL, $fontfile = '', $subset = 'default', $out = true) dans require_once() (line 27 in /srv/data/web/vhosts/www.domain.fr/htdocs/sites/all/libraries/fpdi/fpdi.php).
    Strict warning : Declaration of PdfTemplate::addPage() should be compatible with TCPDF::AddPage($orientation = '', $format = '', $keepmargins = false, $tocpage = false) in require_once() (line 24 in /srv/data/web/vhosts/www.domain.fr/htdocs/sites/all/modules/views_pdf/views_pdf_template.php).
    Strict warning : Declaration of FPDF::_putstream() should be compatible with TCPDF::_putstream($s, $n = 0) in require_once() (line 17 in /srv/data/web/vhosts/www.domain.fr/htdocs/sites/all/modules/views_pdf/views_pdf_template.php).
    Strict warning : Declaration of FPDF_TPL::SetFont() should be compatible with TCPDF::SetFont($family, $style = '', $size = NULL, $fontfile = '', $subset = 'default', $out = true) dans require_once() (line 27 in /srv/data/web/vhosts/www.domain.fr/htdocs/sites/all/libraries/fpdi/fpdi.php).
    Strict warning : Declaration of PdfTemplate::addPage() should be compatible with TCPDF::AddPage($orientation = '', $format = '', $keepmargins = false, $tocpage = false) in require_once() (line 24 in /srv/data/web/vhosts/www.domain.fr/htdocs/sites/all/modules/views_pdf/views_pdf_template.php).

Informations :
PHP 5.4.4
TCPDF 6.0.021
FPDI 1.4.4
FPDF_TPL 1.2.3

Thanks for your help.

Comments

please, read documentation
https://drupal.org/node/1086584
FPDI 1.4.4, TCPDF 6.0.020, FPDF_TPL 1.2.3
you have TCPDF 6.0.021

if you get the same warning, please, report here.
l asked killua99 in the chat and he told to me to leave this open for when TCPDF 6.0.021 is supported.
please, dont open a new issue for each problem that you have. try to find if an issue talks about it already to help developers to easy find thing to work.
and thanks very much for reporting :)

Title:Errors notice with last dev versionErrors notice with last dev version and TCPDF 6.0.021
Status:Active» Needs work

with TCPDF 6.0.020 they were solved

Hello,

I tested views pdf with tcpdf Version 6.0.020 and 6.0.021. I still get the same errors. :(
Tcpdf_tpl file is it the problem?

Thanks for your help.

I got theses warning messages for the recommended version. This thing does not work.

@donpwinston and @kumkum29 first, what you get are warnings, not errors :)

second: have you look in the issue cue for this warnings one by one? if you find a solution, please post here the url.

third: since i dont get them, i cant not know why. so, if you simplify your view and go adding each attribute one at the time, you will localize when the warning comes and will help the problem to be solved or to find a trick to avoid it.

  • FPDF::_putstream
  • FPDF_TPL::SetFont()
  • PdfTemplate::addPage()

welcome to the team :)

any update?

Hello Killua99,

Sorry,I'm on vacation for a few days. I havent been able to test your latest remarks. I do it as soon as possible.

Issue summary:View changes

rev2

Hello,

after several weeks, i have tested views_pdf module in a new website.
But i get this 2 warnings in page pdf display:

Strict warning : Declaration of FPDF::_putstream() should be compatible with TCPDF::_putstream($s, $n = 0) in require_once() (line 17 in /srv/data/web/vhosts/www.mysite.com/htdocs/sites/all/modules/views_pdf/views_pdf_template.php).
    Strict warning : Declaration of FPDF_TPL::SetFont() should be compatible with TCPDF::SetFont($family, $style = '', $size = NULL, $fontfile = '', $subset = 'default', $out = true) in require_once() (line 27 in /srv/data/web/vhosts/www.mysite.com/htdocs/sites/all/libraries/fpdi/fpdi.php).

I use php 5.4 on my server.
FPDI 1.4.4, TCPDF 6.0.020, FPDF_TPL 1.2.3

Thanks for your help.

Issue summary:View changes
Status:Needs work» Postponed (maintainer needs more info)

I thinking this is related directly to the library.

The line 17 of views_pdf_template.php is require_once views_pdf_get_library('fpdi') . '/fpdi2tcpdf_bridge.php';

We're calling the external library and the library start to call it self to other pieces. I cannot do nothing about that. The strict warning need to be solved from the library.

I'm working on the branch 2 that I'll remove the support for this library. Because they don't pay attention to this instead I'm gonna use a fork of the same library but with the good corrections.

The current stable branch v1 have any notices?

Hello killua99,

with the latest version (1.3) I have these 2 warnings. Other errors no longer exist.

Thanks.

Awesome kumkum29, Let's hope in the new branch this kind error never appear again or not too much.

Like I said before this error are 100% related to the libraries.

Status:Postponed (maintainer needs more info)» Closed (works as designed)

i'm gonna close this one. Because the libraries it self have warning and notice ... so I'll skip this kind of error for now.

I'm working on the next version which will use diff libraries.

Re open just is 10000% needed please. Thanks.