i have set up my sites to notify of available updates. i am continually being notified that File Entity & Media need to be updated. however, the versions that are being recommended are older than what i have installed (and which are working great).

for File Entity, i have 7.x-2.0-unstable7+84-dev, and for Media i have 7.x-2.0-unstable7+53-dev. i'm being advised to install the 7.x-2.0-unstable7 versions of each -- which did not work very well.

this is a minor issue; i just ignore the recommendations. but it is puzzling, and it's a bit irritating having to double-check that that's all the latest "recommendation" is about. can't Drupal tell i'm perfectly satisfied with my installed modules & please stop annoying me?

Comments

This post is better served in the post installation forum. please edit and move it. Thanks.

the issue is caused because the installation in question is using -dev releases. Update to the newest -dev of each module which are likely newer than what you're currently using based on the date of the last roll and why you are receiving notices. You don't state how you are updating modules. If you are using the core update manager, you may need to update -dev modules manually or with drush. If you've no intent to every update modules simply disable the update manager.module