First, I'm glad to have the "Use PHP eval function…" checkbox. It's a very good solution to balance security with advanced features.
However, PHP Code After Output doesn't seem to evaluate even when the "Use PHP eval function…" is checked. The PHP Code Before works fine with the checkbox checked.

I'm not sure if this should be considered a duplicate of this issue:
#2040739: Why the need for (php_)eval?

Comments

Never ending :)

Well I'm going to check again and see what's going on. Thanks for the report.

Category:bug» support

Which kind of code did you try?

Can put some code to see what do you want to do?? seems like it's not a bug the $content is already executed there and storage in the PDF when you use the eval after is to do something more like for the next row etc ..

I tried it with $this->AddPage(); and $this->writeHTML($html, true, false, true, false, ''); They both work in the before field, but not after.

Category:support» bug
Status:Active» Needs review
StatusFileSize
new770 bytes

Looks like there might have been a typo in the code for eval_after.
Here's a patch (my first!) that fixes the problem for me.

Version:7.x-1.1» 7.x-1.x-dev
Priority:Normal» Major

I'll check that tonight.

Priority:Major» Normal

And yes ... was a huge typo, reviewed and commited.

Issue #2058887 by vegansupreme: Fixed PHP eval after not working.

You can fin it in a few hours in the dev branch. Thanks.

Issue summary:View changes
Status:Needs review» Fixed

Status:Fixed» Closed (fixed)

Automatically closed - issue fixed for 2 weeks with no activity.