Change record status: 
Project: 
Introduced in branch: 
8.x
Introduced in version: 
8.x-3.x-dev
Issues: 
Description: 

Problem/Motivation

  • Currently, many Views method names use underscores rather than camelCase.

Proposed resolution

  • Later in the release cycle, rename classes according to the new standard.
  • Convert method names exactly from underscore_separated() to camelCase(). So,
    foo_the_bar()
    becomes
    fooTheBar().

i.e.:

From To
view_argument_validate_user() viewArgumentValidateUser()
test_plugin_argument_default_current_user() testPluginArgumentDefaultCurrentUser()
test_views_trim_text() testViewsTrimText()

The three above were in the previous version of the issue summary, cf. #4 and #5 below. These three are the only ones not in the list below, which is based on #13.

Before replacing any method names, we must check that the new name is not already in use. Also, #11 suggests that we consider changing to more descriptive names instead of mechanically replacing "camel_case" with "camelCase".

Impacts: 
Site builders, administrators, editors
Module developers
Updates Done (doc team, etc.)
Online documentation: 
Not done
Theming guide: 
Not done
Module developer documentation: 
Not done
Examples project: 
Not done
Coder Review: 
Not done
Coder Upgrade: 
Not done
Other: 
Other updates done