This came up in @yoroy:by
I wonder if it's useful to keep referring to a menu as a block. I.e. the action says 'Place block'. Would it be more clearer if this read 'Place menu'? Same with the messages: I'm working on a menu here, but it's being referred to as a block.
This might apply for other block placement pages and we might wanna generalize the implementation to apply in all cases, so assigning to block.module instead of menu.module.