Updated: Comment #1

Problem/Motivation

#2076085: Resolve the need for a 'title callback' using the route removed the title from the aggregator configuration menu item, which made it so that the title does not display on the Configuration page.

Steps to reproduce

  1. Clean install of Drupal 8
  2. Enable Aggregator module
  3. Navigate to admin/config

What admin/config currently looks like:
aggregator-missing-title-after.png

What we (mostly, ignore the different icons) want it to look like:
aggregator-missing-title-before.png

Proposed resolution

Re-add 'title' to admin/config/services/aggregator in aggregator_menu().

Remaining tasks

Needs a patch created

User interface changes

Title will be correctly displayed in admin/config and in page titles.

API changes

n/a

#2076085: Resolve the need for a 'title callback' using the route

Files: 

Comments

Screenshots.

Issue summary:View changes

Add steps to reproduce and screenshots, improve problem/motivation and proposed resolution

Status:Active» Needs review
StatusFileSize
new611 bytes
PASSED: [[SimpleTest]]: [MySQL] 58,789 pass(es).
[ View ]

Title added.

Status:Needs review» Reviewed & tested by the community
StatusFileSize
new27.44 KB

After apply the patch and clean cache the admin page now looks correct.

admin-config-aggregator.png

Can't we add the title to the actual route instead? We're trying to kill off hook_menu.

Ah, that makes sense. Thanks!

Issue summary:View changes

Add note about different icons in the screenshots

Status:Reviewed & tested by the community» Fixed

Committed 0f4bacc and pushed to 8.x. Thanks!

Automatically closed -- issue fixed for 2 weeks with no activity.

Issue summary:View changes

Fix screenshot URL