Hey I noticed that we're not using the freshest SymfonyCMF Routing component. I was using composer to test some other things and when I did a composer update it updated a whole bunch of things that were out of date. One of them was Routing and here's the patch that brings it up to date.

Files: 
CommentFileSizeAuthor
#5 UpdateSymfonyCMF.patch140.21 KBcosmicdreams
PASSED: [[SimpleTest]]: [MySQL] 59,146 pass(es).
[ View ]
RoutingUpdates.patch15.9 KBcosmicdreams
PASSED: [[SimpleTest]]: [MySQL] 58,805 pass(es).
[ View ]

Comments

Status:Active» Needs review

Component:documentation» routing system

Not a documentation issue.

Status:Needs review» Needs work

Need to doublecheck that I did this patch right. A number of patches I submitted like this only included additions to the component. I'll do this again.

It is hard to imagine that this is right as the composer file nor the composer lock file was touched by this patch.

Title:Updated Symfony CMF's Routing ComponentUpdated Symfony CMF's Routing Component to v1.1.0
Status:Needs work» Needs review
StatusFileSize
new140.21 KB
PASSED: [[SimpleTest]]: [MySQL] 59,146 pass(es).
[ View ]

OK, I've redid the update to SymfonyCMF Routing 1.1.0 and test Drupal's installation process. Here's the full update.

Status:Needs review» Reviewed & tested by the community

Okie day.

Status:Reviewed & tested by the community» Fixed

Committed and pushed to 8.x. Thanks!

+++ b/core/vendor/autoload.php
index 1db8d9a..bcf9809 100644
--- a/core/vendor/composer/ClassLoader.php
--- a/core/vendor/composer/ClassLoader.php
+++ b/core/vendor/composer/ClassLoader.php
+++ b/core/vendor/composer/ClassLoader.php
+++ b/core/vendor/composer/ClassLoader.php
@@ -49,7 +49,7 @@ class ClassLoader
@@ -49,7 +49,7 @@ class ClassLoader
     public function getPrefixes()
     {
-        return call_user_func_array('array_merge', $this->prefixes);
+        return $this->prefixes;
     }

It is a bit odd that there are so many changes in ClassLoader.php . Can someone just have a look whether they are okay?

I just did the standard:

php composer.phar update symfony-cmf/routing

update procedure. Is that the right way to do it?

I don't know, it just felt wrong. Maybe you had an older/newer version of composer which caused that. I will ask some people later.

newer, I was prompted to update my composer so I did 5 days ago.

Status:Fixed» Closed (fixed)

Automatically closed -- issue fixed for 2 weeks with no activity.

Issue summary:View changes

Updated issue summary.