In commerce_kickstart_search.js the following line is part of the behavior added by the module.

$('.facetapi-checkbox').live('click', function(e) {

The live function has been deprecated as of jQuery 1.7 and completely removed as of version 1.9. In themes that override to newer versions of jQuery, or sites that use the jQuery Update module, this generates an error.

If backwards compatibility is essential then bind can be used instead (which in turn calls on).

If being current is more important, the on function can be used in combination with the jQuery Migrate plugin, so that when the plugin is dropped (i.e. CK no longer supports the older versions) no changes are needed in the actual code.

I don't know what the policy is regarding backwards compatibility, but jQuery version is always an issue with new themes (hence the jQuery Update module and theme overrides).

So, just throwing this out there...

Files: 

Comments

Title:Commerce search error with newer jquery versionsCommerce search error with newer jquery versions (above 1.9)

Category:Support request» Feature request
Priority:Minor» Normal
Issue summary:View changes
Status:Active» Postponed (maintainer needs more info)

@gsbc Could you try creating a patch for the change, that you suggest?

I forward-ported in the $.live workaround from jquery-migrate... works like a charm.

Status:Postponed (maintainer needs more info)» Needs review