Updated: Comment #6

Problem/Motivation

Currently, the module name and setting name are inconsistent for HTTP Basic auth. We should make them consistent.

Proposed resolution

Change basic_auth module's authentication provider name to basic_auth, so that it is consistent.

Files: 
CommentFileSizeAuthor
#7 http_basic-2107483-7.patch6.41 KBStephaneQ
PASSED: [[SimpleTest]]: [MySQL] 59,018 pass(es).
[ View ]
#2 http_basic-2107483-2.patch4.4 KBStephaneQ
PASSED: [[SimpleTest]]: [MySQL] 58,482 pass(es).
[ View ]

Comments

Issue tags:+Novice

This should be relatively simple, adding Novice tag.

Status:Active» Needs review
StatusFileSize
new4.4 KB
PASSED: [[SimpleTest]]: [MySQL] 58,482 pass(es).
[ View ]

Status:Needs review» Reviewed & tested by the community

I wonder if people will be confused and search for HTTP basics in this module, like the Symfony HTTP foundation component.

I think basic_auth is more clear that this is an authentication provider, maybe we should change it the other way around and make everything basic_auth? Any objections against that?

Status:Reviewed & tested by the community» Needs review

Oops, didn't mean to change the status.

I personally don't think it would be a problem, but I'm not opposed to changing it to basic_auth either.

Status:Needs review» Needs work

We agreed on the last REST call to rather go with basic_auth everywhere.

@StephaneQ care to roll a patch for that?

Status:Needs work» Needs review
StatusFileSize
new6.41 KB
PASSED: [[SimpleTest]]: [MySQL] 59,018 pass(es).
[ View ]

Status:Needs review» Reviewed & tested by the community

Looks good to me.

Status:Reviewed & tested by the community» Fixed

Committed 83e1359 and pushed to 8.x. Thanks!

Issue summary:View changes

go with basic_auth everywhere

Status:Fixed» Closed (fixed)

Automatically closed - issue fixed for 2 weeks with no activity.