Last updated January 21, 2011. Created by joachim on May 10, 2008.
Edited by mlncn, Francewhoa, totsubo. Log in to edit this page.

If your Drupal 6 Status report page returns the following error:

GD Image Rotation Low Quality / Poor Performance
The installed version of PHP GD does not support ...

or your Drupal 7 Status report page reports:

GD library rotate and desaturate effects 2.0 or higher
The GD Library for PHP is enabled, but was compiled without support for functions used by the rotate and desaturate effects. It was probably compiled using the official GD libraries from http://www.libgd.org instead of the GD library bundled with PHP. You should recompile PHP --with-gd using the bundled GD library. See the PHP manual.

This error occurs because PHP is missing the GD graphics library or it is not compiled just right. Not all operating systems (platforms) install it as part of PHP.

Select your operating system below for instructions on how to correct this (or see CentOS instructions).

Looking for support? Visit the Drupal.org forums, or join #drupal-support in IRC.

Comments

On Ubuntu Server 8.04.x LTS, PHP5, Drupal 6.x. If your Drupal Status report page returns the following error:

GD Image Rotation Low Quality / Poor Performance
The installed version of PHP GD does not support ...

Here is a solution that worked for me: http://drupal.org/node/540838

---
How to contribute to Drupal.

---
How to contribute to Drupal.

Have followed your instructions above on Ubuntu 9.10 and I get the following error message below!

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
php5-gd: Depends: phpapi-20060613+lfs
E: Broken packages

Therefore to save people time on ubuntu 9.10 don't do this!

i've got the same error...

these instructions doesen't work for me (i have the ubuntu 9.10)

For 9.10, unfortunately, you have to recompile PHP. See the 9.10 page for instructions.

Ubuntu 10.04 works out of the box. None of this has to be done.

I had this problem as well. I have a Debian Lenny box and the instructions above didn't work for me. What did work was adding the php 5.3 sources to the /etc/apt/sources.list and then doing a apt-get install php5 and apt-get install php5-gd

Put the following urls in /etc/apt/sources.list

deb http://php53.dotdeb.org oldstable all
deb-src http://php53.dotdeb.org oldstable all

Then run
apt-get install php5 php5-gd

Baldwin Louie,
BitSprout LLC
http://www.bitsprout.net